12

I have a VNC server running on a Mac. When I try to use a VNC viewer, it says "no matching security types".

Is there any other software which can connect to a Mac like RDP?

If iI use screen sharing from another Mac, then it works but not from VNC.

EDIT: I am using:

  • Leopard 10.5.7,
  • vnc VIEWER 4.1.3,
  • nothing installed on Mac,
  • On Same LAN,
  • Is this the built-in VNC server in OS X? What version of OS X are you running? What VNC viewer are you using? Is this on the same LAN? is there a network device between the two computer like a router or firewall? – Wesley Mar 9 '10 at 1:11
  • I have edited the question – John Mar 9 '10 at 1:35
  • Turn on "Screen Sharing" under preferences on the Mac, go into Advanced, check both boxes, enter a password. -- "Remote Management" will also work, but only with some viewers; if you want to use TightVNC, for example, you need to use Screen Sharing (Remote Management won't work). – BrainSlugs83 Oct 18 '16 at 18:58
  • For me it worked only after disabling the firewall. Afterwards I found apple.stackexchange.com/questions/112046/… – zoechi Apr 8 at 13:50

10 Answers 10

2

Try TightVNC to connect. It seems to work when the free edition of RealVNC does not. http://www.tightvnc.com/

I've also found that the VNC viewer will konk out when connecting to the Mac if the viewer is not running in millions or full color mode.

| improve this answer | |
  • 4
    I tried it and it says , server did not offer supported security type – John Mar 9 '10 at 4:18
  • It also says , no configured security type is supported by 3.3 viewer – John Mar 9 '10 at 4:25
  • That's because of the version conflict I referred to in my answer. – John Gardeniers Mar 9 '10 at 4:26
  • I installe VNC enterprise view , finally it got connected but looks weired like only 16 colors or something – John Mar 9 '10 at 4:34
  • Now TightVNC is also working but the problem is color , TightVNC also shows only 256 colors – John Mar 9 '10 at 5:52
6

I'm not sure which VNC server you have running on your Mac, but you can use the built-in one.

Apple menu --> System Preferences --> Sharing --> Screen Sharing

Make sure that its configured for VNC access with a password. Then try to connect to TCP port 5900 with a VNC client on your PC.

To answer the other question: VNC is the Mac answer to RDP, actually. Even the commercial "Apple Remote Desktop" package ultimately uses the VNC protocol.

| improve this answer | |
  • 2
    I had the same problem and this worked for me. Simply configure a password in the option popup. – PiTheNumber Mar 26 '12 at 13:02
6

I ran this command and could get it to work with RealVNC Open/Free edition viewer. Ensure that on the client, the color level is set to Full [Options->Colour & Encoding->Colour Level]

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -off -restart -agent -privs -all -allowAccessFor -allUsers -clientopts -setvncpw -vncpw secret -setvnclegacy -vnclegacy yes

This method works via the command line (local terminal and remote ssh session too).

| improve this answer | |
  • thank you thank you thank you, it made it work and made my day! – johnshen64 Apr 1 '17 at 12:00
4

A few years later, the "world has changed", so

The free version of RealVNC (v. 6.17.1113, Nov 2017, x64) works smoothly for me. In particular from Windows 7 Professional to OS X Yosemite (10.11) and to OS X High Sierra (10.13 w/ latest updates), the "OS X Authentication" that Mac OS builtin VNC requires, with username and password and no tweaks to the VNC server side, posed no problem. These are security types 30 and 35: see https://vncdotool.readthedocs.io/en/0.8.0/rfbproto.html#security

Although performance was clearly lacking. It's using ZRLE compression; perhaps JPEG or something else is superior, and perhaps professional RealVNC is optimized.

TightVNC and TigerVNC both fail complaining those are unknown codes.

[And do everything over a VPN for heaven's sake if going through the Internet.]

| improve this answer | |
2

Try turning off encryption, works for me for a similar problem.

| improve this answer | |
  • For RealVNC: set Encryption to "Prefer On" or "Prefer Off", the default (Server) will give you authentication errors no matter how correct your password is. – Paul Nov 18 at 20:25
1

From memory you'll need to either use a v3.x viewer or configure the one you have to use the version 3 protocol. How depends on your viewer but it should be covered in its help file or web site.

| improve this answer | |
1

Any VNC client I've tried works. On your Mac

  1. Go to System Preferences -> Sharing -> Enable Screen Sharing
  2. Click the Computer Settings... button
  3. In the drop-down sheet, check both boxes for Anyone may request permission to control screen and VNC viewers may control screen with password:
  4. Enter a password
  5. Click OK button
  6. Leave system preferences

Once you've done that, be sure not to use 256 colors. Then, when connecting from your other computer you should be prompted for a normal VNC password, followed by the OsX login screen, where you can choose the user you'd like to log in as.

| improve this answer | |
1

Had the same problem on El Capitan. TightVNC viewer (version 2.7.10) worked without any problem with Yosemite but failed to connect to Mac after upgrade to El Capitan. Looks like TightVNC 2.7.x does not support VNC protocol used by newer versions of OSX.

I've switched over to RealVNC Viewer (version 5.3.1) which works without any error.

| improve this answer | |
  • Can you get RealVNC work with Sierra? I've been trying to access Sierra from Windows 10 PC without any luck. I keep getting "Timed out" error. Both computers are on the same network and I've turned on Screen Sharing on my Macbook Pro – KMC Aug 26 '17 at 18:29
0

You can encounter this problem if the server does not have a password configured, or the server is running with integrated authentication and you are using the free VNC viewer. The free VNC viewer does not support some of the newer authentication methods.

| improve this answer | |
0

If, like me, you have problems to connect to MacOS from Ubuntu (I know the question was originally for windows, but this might be useful)

What worked for me was: Use Remmina, use the Vnc Password that was setup on Mac as Username, any valid user in the mac system will do. Do not use 256 bit colors

In my case neither xtightvǹc or tigervnc could connect from ubuntu 18.04

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy