I'm using svn+ssh and I see a number of:

Killed by signal 15.

during a svn up.

Any ideas way?

up vote 10 down vote accepted

The message you are seeing is printed by ssh as a result of the fix for svn-issue #2580.

This is expected. You need to add -q to the ssh command invoked by svn, which happens by default as of 1.6.6.

Put this in ~/.subversion/config under the [tunnels] section:

ssh = $SVN_SSH ssh -q
  • To make the solution work, you should put the line into [tunnels] section – Ilia Nedoluzhko Jul 1 '14 at 3:19
  • Note that the fix applied to Subversion somewhere from about 1.6.5 onwards is only to the default ssh setting in your config [tunnels] section. If you have an existing installation with that set, e.g. ssh = $SVN_SSH ssh -o ControlMaster=no, (sans -q) then you will need to add that setting there, as the updated default will not apply. – javabrett Feb 29 '16 at 22:15

The correct answer is:

Add the -q parameter after  "$SVN_SSH ssh" in ~/.subversion/config

In plain English:

If your ~/.subversion/config already has such a line, then edit the line. Else add it.

So, if you are sure there is no occurrence of ssh = $SVN_SSH ssh then add a new line:

ssh = $SVN_SSH ssh -q 

If the line already exists, typically as ssh = $SVN_SSH ssh -o ControlMaster=no then edit it to read ssh = $SVN_SSH ssh -q -o ControlMaster=no

Warning: The order of the parameters seems to matter. ssh = $SVN_SSH ssh -q -o ControlMaster=no works, but ssh = $SVN_SSH ssh -o -q ControlMaster=no fails with the message command-line: line 0: Bad configuration option: -q.

  • 1
    The order matters because 'ControlMaster=no' is a parameter of -o. -o is not a stand-alone flag – Allan Jude Jul 10 '15 at 16:45
 ~/.subversion/config: ssh = $SVN_SSH ssh -q

This doesn't work - I think this is the fix for the previous bug.

[n@g ~]$ svn up /opt/
At revision 1492.
Killed by signal 15.
[n@g ~]$ grep "ssh =" ~/.subversion/config
ssh = $SVN_SSH ssh -q

If it isnt working perhaps you are invoking ssh using something other than the $SVN_SSH variable. http://www.freebsdonline.com/content/view/764/528/ has an example of that.

regarding the warning:

"Warning: The order of the parameters seems to matter. ssh = $SVN_SSH ssh -q -o ControlMaster=no works, but ssh = $SVN_SSH ssh -o -q ControlMaster=no fails with the message command-line: line 0: Bad configuration option: -q."

that is because you placed the -q after the -o which is looking for the option (ControlMaster=no) specified by -o. if you placed the -q after the option, it will work. ie

ssh = $SVN_SSH ssh -o ControlMaster=no -q

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.