I'm migrating e-mail for my domains to Google Apps' e-mail. Most everything seems to work except e-mail sent to any user at (at least) sonic.net is rejected with a message of the form (where any-address has been substituted for my friend's address):

From: Mail Delivery Subsystem <[email protected]>
Date: March 11, 2010 10:04:48 AM PST
To: [email protected]
Subject: Delivery Status Notification (Failure)
Delivered-To: [email protected]
Received: by with SMTP id dw26cs8717qcb; Thu, 11 Mar 2010 10:04:48 -0800 (PST)
Received: by with SMTP id v15mr3841599fai.62.1268330688325; Thu, 11 Mar 2010 10:04:48 -0800 (PST)
Received: by with SMTP id v15mr5119424fai.62; Thu, 11 Mar 2010  10:04:48 -0800 (PST)
Mime-Version: 1.0
Return-Path: <>
X-Failed-Recipients: [email protected]
Message-Id: <[email protected]>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Delivery to the following recipient failed permanently:

    [email protected]

Technical details of permanent failure: 
Google tried to deliver your message, but it was rejected by the recipient domain.
We recommend contacting the other email provider for further information about the
cause of this error. The error that the other server returned was: 550 550 5.1.1
<[email protected]>... No such user here (state 13).

And here are the headers from the message it bounces back:

Received: by with SMTP id s7mr2515885anl.176.1267979929490;
       Sun, 07 Mar 2010 08:38:49 -0800 (PST)
Return-Path: <[email protected]>
Received: from [] (adsl-76-201-171-194.dsl.pltn13.sbcglobal.net [])
       by mx.google.com with ESMTPS id 4sm1046550yxd.70.2010.
       (version=TLSv1/SSLv3 cipher=RC4-MD5);
       Sun, 07 Mar 2010 08:38:49 -0800 (PST)
From: "Paul J. Lucas" <[email protected]>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: quoted-printable
Subject: Some fascinating subject
Date: Sun, 7 Mar 2010 08:38:46 -0800
References: <[email protected]>
To: [email protected]
Message-Id: <[email protected]>
Mime-Version: 1.0 (Apple Message framework v1077)
X-Mailer: Apple Mail (2.1077)

However, I am able to send mail to a user at sonic.net using my old e-mail account. Also, my company uses Google Apps for e-mail and I can send e-mail to a user at sonic.net from my company. The differences between my personal e-mail and my company's are:

  • My company's domain has no SPF record whereas mine does.
  • My company's domain has an A record whereas mine does not.

My SPF record initially was as prescribed by Google here. However, this guy claims Google is wrong and gives a fix. I've tried it both ways with no difference. My SPF record is currently:

v=spf1 mx include:aspmx.googlemail.com include:_spf.google.com ~all

As for the lack of an A record, you wouldn't think that a mail host would care about that so long as mx records are defined.

However, the funny thing is that if you look at the error message, why does Google state that the recipient's domain stated that there is "No such user here" for my address? That makes no sense. Of course there is no user having my address at sonic.net.

Also, I assume that I just discovered that I can't send mail to users at sonic.net by accident and that there are probably other domains I can't send e-mail to.

So... anybody have any idea what's going on? And how I can get mail to users at sonic.net?

  • Another friend of mine who also uses Google Apps for e-mail added an SPF record and he has no problems sending mail to sonic.net. One difference is that he has an A record for his domain. I'll see about adding an A record and then seeing what happens. Mar 11, 2010 at 1:10
  • I just got off the phone with sonic.net's tech support. They don't check SPF, but do check A records. However, they see no evidence in their logs that they ever received any delivery attempt. This means the problem has to be on Google's end. Mar 11, 2010 at 18:27

5 Answers 5


I got a subsequent e-mail from sonic.net's tech support (impressive, especially since I'm not even a customer of theirs) and they said that "the odd IP entries I was seeing smoothing into a more normal setup."

I've since sent test messages, got no bounces, and gotten replies. So it seems mail to sonic.net is working. So the cause was one of 3 things:

  1. My domain lacked an A record (shouldn't matter, but they're using it as an anti-spam measure).
  2. My other DNS changes had not fully propagated.
  3. Maybe Google fixed something (I did contact them with a report of my troubles).

I could delete the A record and see if my problems return to confirm or deny #1. The reason I'm suspicious about it is because I never had an A record with my old mail provider either, and yet could send mail to sonic.net. However, since it's working now, I'm reluctant to touch it.


Maybe sonic.net is doing a reverse DNS lookup and checking to see if that user exists on the sender's mail server (*.googlemail.com), which returns false.

  • But that doesn't explain why it would work when sending e-mail from my company which also uses Google Apps mail (as I stated). Mar 10, 2010 at 4:12

Can you clarify whether or not you are actually sending to a real in use user on that specific domain of sonic.net

A wild card can be set up to catch all non-used users and direct those messages to an admin or whatever user you specify. This has to be done manually if I am not mistaken.

  • Yes, I am sending to a specific user: a friend of mine, which is how I noticed that it didn't work when the mail bounced. The mail also bounced by sending to [email protected]. Mar 10, 2010 at 8:16
  • Also, I don't understand the relevance of creating a catch-all user. Mar 10, 2010 at 8:17

Sonic.net is using 8 different MX servers. It may be possible that one is misconfigured and Google Apps is unlucky enough to keep hitting the bad server(s).

sonic.net       MX preference = 10, mail exchanger = mailin-01.mx.sonic.net
sonic.net       MX preference = 10, mail exchanger = mailin-02.mx.sonic.net
mailin-01.mx.sonic.net  internet address =
mailin-02.mx.sonic.net  internet address =
mailin-01.mx.sonic.net  internet address =
mailin-01.mx.sonic.net  internet address =
mailin-02.mx.sonic.net  internet address =
mailin-02.mx.sonic.net  internet address =
mailin-01.mx.sonic.net  internet address =
mailin-02.mx.sonic.net  internet address = 

If it were me, I would telnet to each of those servers on port 25 and send a test message to the failing address to narrow down the problem.

Edit: Another possibility that just occurred to me - sonic.net has their domain configured on Gmail. This could prevent Google from querying DNS for MX records to submit to and would be a reason why Sonic.net support do not see connection attempts.

  • The problem with that idea is that I'd be connecting from my desktop machine which obviously isn't the same as connecting from Google's MX servers. Mar 12, 2010 at 16:56
  • Very true, but it narrows down the problem. If were to get 550 errors on one of the servers from your desktop, you can rule out Google's servers and SPF.
    – Doug Luxem
    Mar 12, 2010 at 17:40

We reject almost all Google Apps and Amazon ECS servers for email due to the amount of spam that both kick out. Both are listed on numerous blacklists as a result.

Due to abuse, most of Google Apps and Amazon ECS is also blocked at our border since it is a haven for poorly written web bots that don't have the first clue about distributed computing.

  • 1
    This isn't Google's cloud application hosting service, but the service that used to be known as Google Apps For Your Domain where you redirect your mail domain to Google's GMail and they give you a branded GMail and Google Docs.
    – GAThrawn
    Jun 30, 2010 at 15:08
  • Insane, you block google mail? You must be missing a lot of legit mail? Mar 17, 2013 at 5:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .