After rebooting my server Windows 2008 R2 server, I can't log into the remote desktop anymore. When I try to connect, the remote desktop zooms through different status messages, the last of them being "Configuring remote session" and then reverts to the initial Connection dialog again without giving me any error message.

The server is seems to be up, since it's still deliverying web pages. Also, it does seem to be accepting my credentials.

Is there any way to see why the connection fails? I've browsed through my system's even logs, but could not find anything related to remote desktop. Perhaps there's some hidden troubleshooting mode?

Thanks,

Adrian

Edit: In the meantime the server has come back online. I'm not sure if it did so on it's own or if tech support did because I have not heard from them so far, but the problem is solved for the moment. It's a bit disappointing not to know the cause of thep problem though.

  • Quick question - are you attempting to save the connection credentials? – Mr Furious Mar 10 '10 at 20:24
  • Initially I was, but then I also tried without saved credentials. I also tried it from a different terminal. Always the same problem. – Adrian Grigore Mar 10 '10 at 20:52
  • 1
    Adrian - is there anything in the Event Viewer to go on? Did the reboot happen when you had planned it to, or was it more recent? – mfinni Mar 10 '10 at 21:26
  • @mfinni: Please see my answer below – Adrian Grigore Mar 11 '10 at 16:58

Verify that it actually rebooted - if you can do a "net use" against the remote server, then connect to Event Viewer to see if it actually did reboot. I've seen plenty of Win2k3 servers that, when rebooted from an RDP session, don't actually reboot but stop responding to RDP. If that's the case, you can do a shutdown /i against the server or use some other out-of-band method of actually executing the reboot.

And if this is the case, in the future, don't reboot from a regular RDP session. Reboot only from the /console or /admin connection, or use shutdown /i, or other remote methods.

  • Forgive me the dumb question, I'm new to windows hosting since I've only used linux for ages, but can I do all these commands without a remote desktop? So far I have not installed any third party ssh server. Is there a way to connect to the computer's console just as with SSH on linux systems? – Adrian Grigore Mar 10 '10 at 19:28
  • 1
    You don't use SSH for this, "net use" works via NetBIOS over TCP. Do a "net use" to the server from your machine, then on your machine run Computer Management or Event Viewer, and Connect to the remote machine. – mfinni Mar 10 '10 at 19:42
  • @Adrian Grigore, I believe the assumption was that server existed on your local network and you where able to access it via SMB. If the server isn't on your network, then you probably won't be able to do a net use against it since that is probably blocked by firewalls. – Zoredache Mar 10 '10 at 19:43

I had a problem using remote desktop on a server 2003. I connected and after seeing some status messages I was disconnected before seeing the full desktop.

The Problem was, that the server had a wrong time because the synchronization failed for a few month (I think there was a time difference of about 30 minutes).

  • Thanks for the hint, but it doesn't seem to be the problem here. The server is brandnew, just installed it today. – Adrian Grigore Mar 10 '10 at 19:29

After further investigation of the event log, I think I have found the problem. There was this error almost exactly after the restart was initiated:

The Windows Modules Installer service did not shut down properly after receiving a preshutdown control.

So the problem was that some the services were shut down, while this particular service was hanging. It seems to have been killed after a timeout occurred (one hour), after which windows has rebooted as intended.

Now the only remaining question is how to prevent this in the future. Obviously I'd like future reboots to run a bit faster than this...

I got here through Google with the same problem with my Windows Server 2012 (7 years later), so I'll add my own experience with the problem for future searchers. Here's what happened:

  1. In light of the recent WannaCrypt attacks, I installed all pending security updates from Microsoft. Naturally, a reboot was required. For the second time. In less than 24 hours. On a server which was running for 350 days straight before this whole mess. I hope all hackers burn and rot in hell (I'm an atheist BTW, I don't even believe in hell).
  2. I clicked the restart button in Windows Update. My RD session was terminated immediately and all attempts to reconnect would fail with no error message, but the server was still up and running uninterrupted and serving pages. I know this because my AppPool takes one or two minutes to fully load each time it's taken down. I'm guessing that Windows Update was going through some preliminary steps which didn't require other services on the system to be shut down.
  3. After a few more (very long and stressful) minutes, the server would return HTTP 503 for all requests. I could still ping the server though. Guess: server still running, IIS shut down, more serious update work in progress.
  4. A minute or so later, I lost all access to the server. No kernel, no Windows, nothing, waiting for the system to come back online after the actual reboot.
  5. After another minute, the ping was back, and I actually managed to connect to RD in time to see the final steps of the update being applied. Server is running normally since.

So, if you lose remote access to your server immediately after reboot, don't panic, it's probably doing some maintenance work and will come right back online after it's done.

Remote Desktop can also behave oddly if you have older graphics drivers. On a server, I wouldn't think this would be an issue, but updating the graphics drivers is something else you can try. (It fixed a similar issue on an XP SP3 machine for me.)

its good, if its resolved but for the future references, I am adding these lines;

  1. Remote Desktop will work, once the Server is UP and Login Screen is appeared after Restart. Usually, all ICMP (Ping) and Services (Web / Domain etc.) become available but Remote Desktop required server to be fully up and running.
  2. If server is restarted and you are expecting that there might be someone else already connected, you can try the mstsc /admin. This will help you to login/bypass the limit of two logins on the server.
  3. Just to cover one more thing in this answer which is not for this but is related to this, Outdated entry in the DNS cache may also be one thing to consider but it clearly tells your about the error.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.