8

Over the years various versions of .NET have been deployed to my client machines via WSUS. Now it seems that on many machines these installations have hosed eachother, and certain .NET security updates are failing.

I verified that I can run the .NET cleanup tool to get rid of all the .NET installations on a client, and I can then push out .NET 3.5 via WSUS. This seems to have solved the problems I'm having on the machine I tried it on.

So the question is: if I've got .NET 3.5, is there any reason to also have previous versions installed?

3 Answers 3

14

Backwards compatible is a bad term to use. .NET 1.0, 1.1, and 2.0 are their own frameworks that have no compatibility between each other. .NET 3.0 and 3.5 are super sets of the 2.0 framework, using the .NET 2.0 base framework, with additional dll's to provide additional features (3.0 included things like WCF and WWF, 3.5 had things like LINQ). In terms of application requirements:

  • 1.0 apps requires .NET 1.0 to be installed.
  • 1.1 apps requires .NET 1.1 to be installed.
  • 2.0 apps requires .NET 2.0, 3.0, or 3.5 to be installed.
  • 3.0 apps requires .NET 3.0 or 3.5 to be installed.
  • 3.5 apps requires .NET 3.5 to be installed.

I'm fairly certain that .NET 4.0 follows the same model as 2.0 - 3.5 (2.0 base with additional feature dlls). So installing .NET 3.5 will cover you for .NET 2.0 - 3.5 applications. You'll need to install .NET 1.1 if you run any 1.1 apps (same for 1.0 apps).

4
  • 4
    I'm pretty sure .net 4 is a completely new CLR which runs side-by-side with any previous versions--it's not just an expansion pack like 3/3.5 was Mar 11, 2010 at 18:36
  • @Michael - Still haven't found definitive info, but it appears you're right. My bad.
    – Evan M.
    Mar 11, 2010 at 20:59
  • +1. Awesome answer. I can't tell you how many times I've had to explain this to our support engineers.
    – joeqwerty
    Mar 12, 2010 at 0:45
  • 2
    msdn.microsoft.com/en-us/library/bb822049.aspx is an article that confirms what you state above. And yes, the 4.0 is stand alone, has no dependencies on other versions. Jun 5, 2010 at 22:31
2

.NET is backwards compatible to an extent, but you have to compare between versions of the framework. What they do state is that it is side-by-side compatible, which is the problem you're faced with. There is definitely a reason to have other versions installed. An app can be written to target a specific version and if this version is not present on a machine then the app will fail.

3
  • That's kinda what I thought. I guess I'll have to do this on a machine by machine basis.
    – Boden
    Mar 11, 2010 at 16:54
  • @Boden: you can usually switch the app to target a different framework, but it requires modifying an app.config or a web.config file for the app. I would highly advise against this, however, as that could introduce a whole slew of problems for the app and thus totally break it.
    – squillman
    Mar 11, 2010 at 16:58
  • You'll probably get some really good coverage by deploying 3.5 now, and 4.0 when it is released in April. 3.5 has the same CLR as 2 so you don't need to do 2 and 3.5. Very few apps run 1.1 anymore so you could leave that off and include it only in the rare case that it is required. Mar 11, 2010 at 18:37
-1

No, .net is not backward compatible. MS reserves the right to make changes. 2.0 u to 3.5 are IIRC, but that is more a "lucky side". The concet is th have al frameworks installed that are needed, and an application targets the framework it was compiled against - this allows MS to clean up new versions and introduce non-compatible changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.