I have almost fresh Ubuntu desktop box. OS was installed two weeks ago and updated from karmic repositories. Last week I had no problems with DNS. But this week something had changed. I'm not sure what and when, and not sure whether I changed any configs.

So now I have some really weird situation. According to logs name resolving should work normally.

/etc/hosts   localhost test   desktop


order hosts,bind
multi on


# Generated by NetworkManager
search search servers obtained via DHCP


passwd:         compat
group:          compat
shadow:         compat

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis

But if fact it is not.

user@test ~>ping test

PING localhost ( 56(84) bytes of data.

Pinging is ok.

user@test ~>host test

test.mydomain.com has address xx.xxx.161.201

I suspect that NetworkManager might cause this misbehavior, but don't know where to start to check it. Any thoughts, suggestions?


With this configuration, most applications will happily work with your entry from /etc/hosts.

However host doesn't look at /etc/nsswitch.conf. That is by design, not by accident, since host is specifically a DNS lookup program. /etc/hosts is not DNS, it's (mostly) what we used before we had DNS.

The same is also true for dig and nslookup - they're DNS specific too.

| improve this answer | |
  • So, you're saying, host utility doesn't use /etc/hosts? And there's nothing to fix in my case? – z4y4ts Mar 12 '10 at 15:20
  • yup, pretty much - nothing to see here :) – Alnitak Mar 12 '10 at 15:34
  • What I don't get is that host >used to< be the "regular" name-querying command, obeying /etc/nsswitch.conf – mveroone Dec 21 '15 at 10:45
  • @Kwaio I can find no evidence in the ISC sources that host ever did – Alnitak Dec 21 '15 at 15:11
  • Well I might have used unsual distribution implementations, then, my bad. – mveroone Jan 7 '16 at 8:31

The host command (along with dig and nslookup) is part of the bind DNS utilities. As a DNS resolver utility, it does DNS resolution alone.

If you're interested in fetching an entry from any libnss-driven data store, you can use the getent program. To get a hosts entry, for example, use it like this:

getent hosts google.com

This follows the resolution order set out under hosts: in /etc/nsswitch.conf in order, which includes /etc/hosts if "files" is lised as one of the options.

| improve this answer | |
  • Thank you for reminding me the getent command. – Emmanuel Sep 26 '16 at 18:15
  • 3
    I believe that nowadays one should be using getent ahosts instead of getent hosts because getent hosts uses gethostbyaddr() or gethostbyname*() which are obsolete. If I have understood correctly, getent hosts emulates how old UNIX C programs used to work and getent ahosts emulates the way moderm programs should work. – Mikko Rantalainen Oct 2 '17 at 6:09

For me this issue occurred due to incorrect file permissions. Only root could read /etc/hosts. The file should be world-readable.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.