I am trying to install Satchmo 0.9 on an Ubuntu 9.10 32-bit guest off of the instructions at http://bitbucket.org/chris1610/satchmo/downloads/Satchmo.pdf. I run into difficulties at 2.1.2:

pip install -r http://bitbucket.org/chris1610/satchmo/raw/tip/scripts/requirements.txt
pip install -e hg+http://bitbucket.org/chris1610/satchmo/@v0.9#egg=satchmo

The first command fails because a compile error for how it's trying to build PIL. So I ran an "aptitude install python-imaging", locally copy the first line's requirements.text, and remove the line that's unsuccessfully trying to build PIL. The first line completes without reported error, as does the second.

The next step tells me to change directory to the /path/to/new/store, and run:

python clonesatchmo.py

A little bit of trouble here; I am told that clonesatchmo.py will be in /bin by now, and it isn't there, but I put some Satchmo stuff under /usr/local, create a symlink in /bin, and run:

python /bin/clonesatchmo.py

This gives:

jonathan@ubuntu:~/store$ python /bin/clonesatchmo.py 
Creating the Satchmo Application
Traceback (most recent call last):
  File "/bin/clonesatchmo.py", line 108, in <module>
  File "/bin/clonesatchmo.py", line 47, in create_satchmo_site
    import satchmo_skeleton
ImportError: No module named satchmo_skeleton

A find after apparently checking out the repository reveals that there is no file with a name like satchmoskeleton on my system. I thought that bash might be prone to take part of the second pip invocation's URL as the beginning of a comment; I tried both:

pip install -e hg+http://bitbucket.org/chris1610/satchmo/@v0.9\#egg=satchmo
pip install -e hg+http://bitbucket.org/chris1610/satchmo/@v0.9#egg=satchmo

Neither way of doing it seems to take care of the import error mentioned above.

How can I get a Satchmo installation under Ubuntu, or at least enough of a Satchmo installation that I am able to start with a skeleton of a store and then flesh it out the way I want?


I solved "ImportError: No module named satchmo_skeleton" problem by running the command python ../../../scripts/clonesatchmo.py from the apps or projects folder in which skeleton and simple is present.


I had the same problem when I tried Satchmo a while back. Some mailing list hunting turned up a problem with the packaging. A directory isn't copied over correctly.


You just need to copy that directory over to your satchmo site-packages location and it should pick it up as it will be on sys.path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.