Some PuTTY settings are valid only for the current session, and when I start it again, they are at the default value again. How can I change the default values?


2 Answers 2


Make your settings changes and then click on "Default Settings" under "Load, save or delete a stored session" (This is in the "Session" category) to select it. Then click "Save."

  • 3
    right-click Putty bar > Session > enter or click name of your setting > Save
    – Doug Null
    Commented Jan 18, 2016 at 19:46
  • @charlesross It's only used for server administration if you don't have ssh. Since SSH comes with the vast majority of operating systems, you must be talking about server admins that use Microsoft Windows. This is the most minor reason of all to pity them. Commented May 10, 2016 at 13:16

I'm often bitten by that too.
What usually happen is, you set some options (usually just host/port) and save it.
Then latter you:

  • open putty
  • select your "saved session" (either by just selecting it by clicking on the name or selecting and clicking the load button[1])
  • change some other options
  • and connect by clicking the "Open" button

To make it work the way you expect, try doing it this way:

  • open putty
  • select the session you want to edit (click on its entry under the "Session" category)
  • Click the "Load" button
  • Make the changes you want to make
  • Go back to the "Session" category
  • Make sure the name of your saved session is correctly filled on the textbox for "Saved sessions"
  • Click save

To change the default settings, just do the same, but selecting the "Default Settings" entry on the "Saved Sessions" list.

Hope that helps

[1]: yeah, the UI is really not clear on how you're supposed to do it

  • 3
    posted some screenshots on how to do it here: serverfault.com/questions/52068/… Commented Aug 10, 2009 at 1:59
  • The counter-intuitive step is that, after changing the settings, you have to click on Session to get back to the only frame that contains a Save button. Commented Mar 26, 2019 at 7:37

Not the answer you're looking for? Browse other questions tagged .