Now that I'm down to the last part to install the FFMPEG it tells me to do the following

cd /usr/local/src/ffmpeg/

./configure --enable-libmp3lame --enable-libogg --enable-libamr-nb --enable-libamr-wb --enable-libvorbis --disable-mmx --enable-shared
make install

ln -s /usr/local/lib/libavformat.so.50 /usr/lib/libavformat.so.50
ln -s /usr/local/lib/libavcodec.so.51 /usr/lib/libavcodec.so.51
ln -s /usr/local/lib/libavutil.so.49 /usr/lib/libavutil.so.49
ln -s /usr/local/lib/libmp3lame.so.0 /usr/lib/libmp3lame.so.0
ln -s /usr/local/lib/libavformat.so.51 /usr/lib/libavformat.so.51

When I get to the part

./configure --enable-libmp3lame --enable-libogg --enable-libamr-nb --enable-libamr-wb --enable-libvorbis --disable-mmx --enable-shared

I get the error

Unknown option "--enable-libogg".
See ./configure --help for available options.

I've tried removing the --enable-libogg but it does not seem to help.

  • Does ./configure --help help? It should show you if this is valid. What errors do you get when you removed this option? – Richard Holloway Mar 16 '10 at 14:39
  • This is a question better addressed to stackoverflow.com. One thing that comes to mind, is that you need to write the ./configure line yourself, there might be some problem with copypaste characters. – tstm Mar 16 '10 at 15:03
  • @tstm, I disagree. It is not about programming, which is the domain of StackOverflow. I'd suggest SuperUser.com is more suitable, but that might be splitting hairs. – mctylr Mar 16 '10 at 15:16

First, which version of FFmpeg are you trying to build? 0.5.1, or from Git or Subversion?

Assuming it is version 0.5.1, --enable-libogg is not a configure flag, so I don't know why you think you need it. In fact other than --enable-libmp3lame I'm not sure why you have those flags specified. In particular --disable-mmx strikes me as odd.

So in other words. Build it without the --enable-libogg flag. It doesn't appear to need it.


I tried ./configure --enable-libmp3lame --enable-libamr-nb --enable-libamr-wb --enable-libvorbis --disable-mmx --enable-shared --enable-nonfree and it worked with version ffmpeg-0.5.1.

I don't know what else to say.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy