1

ok, this is really pissing me off

I have one ubuntu 8.04 instance running on vmware (esx) which decided after a reboot to stop resolving dns requests, I also cant connect to it using ssh although I can ping the server and its really that server (when I shutdown the server the ping also stops)

stuff I tried: - reboot again :) - nslookup - serverip - setting networking to dhcp - offering some cute kittens to lucifer - removing the virtual nic and adding another (to get a different mac) - migrating the instance to another esx host - drinking 20 cups of espresso - stopped all services - running dnsmasq on another server and connecting to that dns - tcpdumping - disabling ip6

symptoms:

  • cant resolve anything
  • nslookup just says "no servers found..." although I can ping the servers
  • traceroute to gateway doesnt work (even with traceroute -4 -n gatewayip)
  • collegues laughing at me

any thoughts


solved it:

a collegue told me to upgrade/reinstall the vmware tools, I did and it solved my issue after rebooting

1

Have you checked your /etc/nsswitch.conf? This file specifies configuration values for some functions in the C Library and any monkey business in here can cause DNS resolution problems.

The default /etc/nsswitch.conf on my 8.04 hosts looks like this:

# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat
group:          compat
shadow:         compat

hosts:          files dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis
  • thx, we allready checked this – hoberion Mar 24 '10 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.