I just setup SVN on a server that is running Ubuntu server as a fresh install. I've got it up and running but am having difficult determining how to connect to it.

I'm trying to do an import using the local IP address: http://IP/RepositoryName but it's saying it can't resolve the IP. I'm wondering if there's something on the server I need to setup.

I have not modified dav_svn.conf because there is another server here that is running SVN (I'm migrating it to a new server) and it's dav_svn.conf is not modified. The current working SVN has a subdomain associated with the IP location of the server but doesn't do anything special with the ports as far as I can tell.

I'm getting this error via RapidSVN when I try to import...

Error: Error while performing action: OPTIONS of 'http://IP/RepositoryName': could not connect to server (http://IP)

Any help would be appreciated

Update: I'm now connecting to the server (didn't realize Ubuntu server came naked without apache, and ssh) and getting the response

svn: OPTIONS of 'http://IP/RepositoryName': 200 OK (http://IP)

when I run a checkout. It sounds to be like there's a disconnect between apache and the SVN service.

  • I guess you did copy the error message and replaced your ip address with 'IP' and the repository name with 'RepositoryName', right? I'm asking just to be sure... can you provide mor output? Ping the IP, etc? – lajuette Mar 23 '10 at 19:07
  • Yes I replaced the info. I can ping the IP just fine from multiple locations within the office. – Webnet Mar 23 '10 at 19:09
  • Try using the command line client and see what it says. Also check your firewall settings on the SVN server and what your apache access log files say. – 3dinfluence Mar 23 '10 at 19:14
  • And you're sure Apache is running and the module is enabled? – Rugmonster Mar 23 '10 at 19:23

could not connect to server (http://IP

Suggests that it is unable to connect a web server listening (default on port 80) at the IP address.

Using a numeric IP address (e.g. there is no name "resolving" to be done, so that is not failing.

Can you access the web server itself (e.g. from the system that you are getting their error via RapidSVN?

If the system does not have a web browser, then telnet or netcat will do, telnet IP 80 or nc -v xxx.xxx.xxx.xxx 80. Hit "enter" or "return" when it connects.

Is http the correct access method for your SVN server? For example, svn://IP/RepositoryName and svn+ssh://IP/RepositoryName are other examples of different methods.

I'm assuming you have read and followed the outline at Ubuntu's help on Subversion.

I hope this helps.

Based on your feedback, it sounds like there is a problem with the web server serving to the client portion of SVN repository.

So you can work on debugging this part of the problem. Things to consider are:

I originally assumed this, but you should verify that it is correctly configured and working if you haven't already. Can you ping the router or gateway, ping gw.example.com? Is DNS resolving, host www.google.com? Can you ssh to and from the server?

  • Is Apache installed and running?

The simplest way to check this is using the Synaptic Package Manager, and search for the apache2 package. To see if the web server is running, ps ax | grep apache2 (note: some systems use the name httpd instead of apache2).

Is this is the problem, then following the Ubuntu Apache2 Web Server guide should help you get Apache installed and configured enough that you can enable the Subversion access via http.

  • Is SVN setup working?

Can you locally (on the server itself) checkout from the repository you set up? svn co file:///Repository

Once you know that the repository is setup, then you can edit the Apache config file to include Subversion support.

Good luck, you seem to be doing well so far.

  • This is my first time ever setting up a server, so there's a hard learning curve. I mean, I've been over that stuff sort of. It's very confusing cause I've read so many different sources I'm not sure what I'm missing. Apparently I didn't have SSH installed on my server which I've now got up and running. I am not able to access the IP via a web browser and am installing netcat now... – Webnet Mar 23 '10 at 19:53
  • when I execute "nc -v IP" it is unable to find the host.... this is after I have installed netcat.... I also still cannot access the IP via a browser. – Webnet Mar 23 '10 at 19:59
  • I hadn't installed apache because I was told it didn't need it to run. Is that a completely stupid statement? I appreciate the encouragement and assistance, I'm knee deep in this and am totally new to it. It'll be about 2.5 hours before I can mess with the server again. – Webnet Mar 24 '10 at 13:34
  • It depends whether you really want to be able to access the repository via http. If so, then yes you do need Apache. If don't mind using the svn: access method, then you can use Subversion's own svnserve daemon as per help.ubuntu.com/community/… – mctylr Mar 24 '10 at 14:24
  • I'd prefer to be able to access it via HTTPS... so I'm guessing I need apache – Webnet Mar 24 '10 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.