I've recently updated my Subversion package on Debian Etch to 1.5.1 via a back-port. I've gone through what I believe are all the appropriate steps but cannot for the life of me get past the following error message when I try to merge:

Retrieval of mergeinfo unsupported by '.'

The '.' isn't important as I get the same message whether I'm SSH'd on to the server or using TortoiseSVN through Windows.

I'll take you through what I did to upgrade and test step by step:

Update of Subversion

Added the following line to /etc/apt/sources.list:

deb http://www.backports.org/debian etch-backports main contrib non-free

and then ran

apt-get -s -t etch-backports install subversion

Checked the version of the subversion installation

Done this by running

svnadmin --version

and got the following output:

svnadmin, version 1.5.1 (r32289)
compiled Dec 11 2008, 18:10:14

Checked the client too using

svn --version

and got the following

svn, version 1.5.1 (r32289)
compiled Dec 11 2008, 18:10:14

Ok, so all looking good so far.

Now I just need to upgrade the repository. After plenty of research, the most foolproof way to do this seemed to be to dump the repository and then load it again. So here's what I did:

svnadmin dump /var/svn/repo > repo.dump

rm -aR /var/svn/repo/*

svnadmin create /var/svn/repo

svnadmin load < repo.dump

All that seemed to work fine. I then checked to see if the repository had been upgraded by looking at the contents of /var/svn/repo/db/format which gave:


layout sharded 1000

Again this indicated a Subversion 1.5 repository so all looking good.

Now I try and do a merge using the Subversion client in Debian:

svn mergeinfo https://mysvn/repo .

and I get the following error:

svn: Retrieval of mergeinfo unsupported by '.'

I get the same error message whether I'm using the Debian shell on the same server or if I'm connecting via TortoiseSVN and a Windows box.

If I browse to the repository using my web browser, the version number at the bottom reads:

Powered by Subversion version 1.4.2 (r22196).

In case it helps, the created date on mod_dav_svn.so is 2009-08-06 18:29

I just cannot figure out why I'm getting this message so any help pointing me in the right direction would be greatly appreciated. All the forum and mailing list posts that I found relating to this error were solved by doing an svnadmin upgrade, though I have actually tried that and still no joy.

Thanks in advance,


2 Answers 2


It looks like your server version is too old (1.4.2). Your client, svnadmin, and repository are all at least 1.5, which is good, but I think your server itself needs to be at least 1.5 as well to support a "merge --reintegrate"


It was the mod_dav_svn module that was out of date. I fixed this by running the following:

apt-get -t etch-backports install libapache2-svn

Thanks to the Subversion users mailing list for pin-pointing this.



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .