I have recently tried to deploy Adobe Reader 9.1 onto our network here. (SBS 2003 server and XP Workstations)

I followed the instructions for the extraction of the installer and .msi and then creating a .mst transform file to set custom options. (Suppress EULA, dont create desktop icon etc)

I then added the package to my deployment GPO applied the relevant .mst file and preceded to deploy accross the network. The software package is computer assigned to be installed prior to logon, to avoid user permissions issues.

The package deploys correctly to computers and will run perfectly fine if you run from a shortcut, however when trying to view a pdf from within a web browser it fails with the following message.

"The adobe acrobat/reader that is running can not be used to view PDF files in a web browser. Adobe Acrobat/Reader version 8 or 9 is required. Please exit and try again"

I have found many pages on google refering to this problem, but none appear to be in relation the problems I have found.

http :// kb2.adobe.com/cps/405/kb405461.html

These fixes recommend correcting a registry entry (which i should mention is missing after the deployed installation. However this does not work.

Switching off display in a browser - Seems to defeat the object of fixing the problem

Removing old versions - There arent any.

Trying with a different user - This affects all users of all privalige levels on all computers.

On my workstation I uninstalled Acrobat Reader 9.1 then reinstalled manually using the same installation source files and it works fine.

has anyone sucsessfully deployed AR9.1 on their domain and if so how?

For the time being I have downloaded the older 8.1.3 release and deployed this in the same way which works fine, but would like to be using the up to date version.



I've never encountered that issue but I have deployed Acrobat Read 9.1 by GPO exactly how you describe and worked great.

I am using Windows XP PRO SP3 & IE 7 on all workstations. Not sure if you're browser has something to do with it, I didn't see the version you used.

As a thought, try it without the transform see if works (just use the MSI). Then if it does work, create basicly a blank transform And then add one option to the transform at a time until it breaks.

  • will try that out on my vm and post back how i get on. thanks
    – Ben Gillam
    Jun 3 '09 at 7:29
  • i thought i had already tried without a transform and it failed however on vm and then on my own pc it seems to deploy ok. As far as the mst goes only thing is desktop icon and eula. maybe some kind of bug perhaps when processing the mst file? I think i'll just leave as is as the changes arent that important. Thanks for your help.
    – Ben Gillam
    Jun 3 '09 at 9:12

This is occuring because apparently support for "in-browser" PDF viewing was removed from this version. I ran into the same problem, and you need to disable an option:

  • Open Adobe Reader
  • Click Edit > Preferences
  • Choose the "Internet" category
  • Uncheck "Display PDF in browser"

Now when you try to open a PDF link, it will open Adobe Reader, instead of opening the PDF within the broswer.

You will want to edit your MST file to disable this option as well.

  • looks like this might be the only way, but seems odd that a manual install works with with open in browser but not when deployed. I'll never understand adobe!
    – Ben Gillam
    Jun 3 '09 at 7:29

You may be missing a registry file [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Adobe\Acrobat\Exe] @="\"C:\Program Files\Adobe\Reader 9.0\Reader\AcroRd32.exe\"". Adding this in fixed the problem for me. Now I just need to work out how to distribute it in the MSI/MST.

See http://www.appdeploy.com/messageboards/printable.asp?m=38727 for more.

  • hi there, thanks for the post. unfortunatly in my case it still ignored the setting when installed manually. As far as adding the key you can make a transform file that will do it, in fact i think adobe's reader 9 customisation wizard app allows you to add custom reg entries. So far the only way around this i found was to just not make a transform file at all and run a standard install which isnt ideal. :(
    – Ben Gillam
    Jun 26 '09 at 14:32

We've seen this issue on systems that had the pro version of Acrobat (not free Reader) installed as well.

9.4 is out now and it may have fixed this issue. Here is an easy and free way to deploy Adobe Reader. Here is another (older) blog post which contains a video tutorial for installing Adobe Reader.

  • I have removed your signature from this post. Please familiarise yourself with the FAQ - specifically the section titled Can I use a signature or tagline?. Feb 7 '11 at 23:44
  • Thank you for the reminder. Consider myself refreshed. Thx. Feb 8 '11 at 0:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.