This is totally server fault i think. :)

I have a site that disabled in Apache but server still serving it. I tried to stop/restart the server with no success. How can i debug this?


OS: Debian

Server: Apache2

Site disabled with a2dissite, config file removed automatically from sites-enabled.

Thanks, fabrik

  • How is it disabled? What platform (Windows/Linux/?) Can you a relevant portion of your Apache config. – Zoredache Mar 25 '10 at 8:04
  • Did you reload the configuration? – Dan Andreatta Mar 25 '10 at 9:23
  • yep, and tried with other sites too where Apache normally disabled/enabled them. – fabrik Mar 25 '10 at 9:24

You should take a look in /etc/apache2/httpd.conf, /etc/apache2/conf.d/, /etc/apache2/sites-enabled/. I think it'll be easy to find out even if you don't have much experience with apache.

  • no success, most of them are the defaults. site configs stored in sites-available and sites-enabled. – fabrik Mar 25 '10 at 9:03
  • Remove the config file from site-enabled. I've never used a2dissite but after you remove the site, the config file should not be in site-enabled directory. – Gk. Mar 25 '10 at 9:16
  • As i wrote in the opening post, config file removed automatically. When i disable any other site Apache working normally. – fabrik Mar 25 '10 at 9:20
  • 1
    Sorry for misunderstanding. Can you find something using this command: find . | xargs grep site_name – Gk. Mar 25 '10 at 9:36
  • That's it! Absolutely no idea how but another config pointed to this domain. Thank you Gk! – fabrik Mar 25 '10 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.