I've set up a turnkeylinux lampp server in virtualbox with two network bridged connections, one for when I'm plugged in to my router, and one for when I'm using a wireless connection. This allowed me to pull up the turnkey control panel on the host machine's browser, but when I try going into the command prompt in the guest and run an apt-get update, it doesn't seem to have an internet connection, even though it seems to have a connection with the host.

What could be wrong?

Thank you very much in advance for any answers...!


A number of suggestions: a) in your guest OS, when you run "ifconfig -a", can you see the network interfaces? If so, have you tried running "dhclient ". Is your network set up to provide IP addresses via DHCP? Do you need to register the MAC addresses to get IP addresses? b) there is a known problem with bridged networking over wireless connections. This has to do with the fact that for most wireless chipsets the device driver cannot be put into promiscuous mode (which is required for bridges). In other words, unless you are really, really serious about it, don't even try that. c) Is your network adapter in VirtualBox set to "host". If not, it will otherwise default to some limited NAT connection, which won't work with your bridge.

  • a) I got 3: eth0 (the cabled connection that I usually don't use - it had an inet6 addr, but not inet), eth1 (the wireless which I am using had inet addr also), and lo (inet; what is dhclient? By using a bridged connection in vbox I thought that if successful (which it reports it was), it fetches an ip from dhcp - I didn't need to enter an ip myself... b) I thought that once I got an ip from dhcp, that showed the problem was resolved? My only problem is that the internet connection is missing, but the network is there c) I set it to bridged adapter with Dell Wireless WLAN.. – user38828 Mar 27 '10 at 21:37
  • I think I have a lead on the problem! I tried ping archive.ubuntu.com, and it gave me 'unknown host'; but when I tried ping it seems to connect and send packets fine... Could there be some kind of dns configuration to do? Thanks for the help, again! – user38828 Mar 27 '10 at 22:27
  • Well, I think it's actually a bit more complicated than that. If you want to use a bridged connection in VirtualBox, then your host OS needs to have an active bridge, with the eth0 configured into it. Without a bridge there is no way that your guest OS will get a network connection. And, as mentioned before, do yourself a favour and start with the wired connection. There is plenty of documentation on how to set uo a bridge. Once you have that, you need to add a virtual interface to the bridge (see VirtualBox documentation). Then we'll talk again. – wolfgangsz Mar 30 '10 at 9:10

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy