When I attempt to connect to a server running XP x64 (so essentially Server 2003) using a PPTP connection, it fails with client-side error

Registering your computer on the network...

Error 720: A connection to the remote computer could not be established. You might need to change the network settings for this configuration.

and server-side error

Event ID: 20050

The user WINSERV3\Andy connected to port VPN8-1 has been disconnected because no network protocols were successfully negotiated.

I have configured the router to pass both TCP packets on 1723 and GRE packets. I have used Wireshark (filtering out ARP, UDP, and all TCP ports other than 1723) to observe the packets received by the server. Wireshark does not explicitly name any protocol GRE, but it does tell me the server sent and received TCP, PPTP, PPP LCP, PPP CHAP, PPP CBCP, and PPP IPCP. The connection seems to go wrong at packet 30, where the protocol is PPP LCP, with the payload of the packet being labeled "Protocol Reject". Obviously, this is going from server to client.

This would seem to lead to the conclusion that there is something wrong with my client, which runs Windows 7 Ultimate x64. However, it is able to connect to my house's router, which runs the DD-WRT firmware and is thus a PPTP endpoint. I'm thoroughly at a loss. Please help!

Do not to use DHCP to assign an IP, and specify a range manually instead for the incoming connection. Thats what fixed it for me.

  • 1
    Also fixed it for me. – Max Apr 19 '12 at 15:06
  • it works for me too! – Codler Dec 28 '12 at 11:22
  • This worked and here is how to get there on WServer2012: Search for Routing & Remote Access --> Right click on your server --> Properties --> IPv4 --> Choose "Static address pool" --> Then add a range of IP's. – Shaz Jun 13 '13 at 15:21

Not using DHCP has fixed it for me too. But only partially! Alas, when opening more than one connection, I received the same error and serverside EventID: 20050 (no network protocols were successfully negotiated) along with EventID: 20167 (No IP address is available to hand out to the dial-in client). The IP range pool I have set had 8 available IP addresses, so it didn't make a lot of sense. Resolution: Splitting the initial 8-IP-addresses pool into 4 pools, 2 IPs each. And it worked!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.