I have Debian (Kernel 2.6.26-2-686) installed on two computers. On one of them it reboots quite finely but I am having following problem with rebooting Debian on my second computer.

When i type reboot at the Linux prompt, following messages appear and system hangs up after saying "Restarting System":

Broadcast message from root@myname (tty1) (Sun Jan 17 11:23:26 2010)

The system is going down for reboot NOW!
INIT: Switching to runlevel: 6
INIT: Sending processes the TERM signal
Saving system clock
Stopping enhanced syslog: rsyslogd.
Asking all remaining processes to terminate...done.
Deconfiguring network interfaces...done.
Cleaning up ifupdown....
Deactivating swap...done.
[ 31.789103] Restarting System.

Normally when the sytem is busy _ sign blinks but _ at the last line above does not blink which shows, the system hanged up. I tried all keys but the screen is still frozen at the same point.

The difference that I noted between my two computers is that I don't have ACPI support in the BIOS of the system which is giving me this error whereas the BIOS of my first computer do have ACPI support on which Debain do not give this restart-hanging problem.

I have also disabled running the acpid script by running

update-rc.d -f acpid remove

but the problem still persists on the second computer.

Any ideas to solve or get around this problem?


The computer on which I am facing this problem is DELL Optiplex 330 (2.8 GHz, 1 GB RAM)

6 Answers 6


for debian squeeze amd64 on Dell latidute 390MT, with sandy bridge use reboot=pci

in details :

$>sudo nano /etc/default/grub change the : GRUB_CMDLINE_LINUX_DEFAULT="quiet" to : GRUB_CMDLINE_LINUX_DEFAULT="reboot=pci quiet"

(cltr+0, cltr+x)

$>sudo update-grub

reboot now works perfect/


Thanks for all those who helped. :)

I tried passing "reboot=bios" as kernel option. This solved the reboot hanging problem. My system is no more hanging now.

Read this for details on passing kernel options and seeing alternative values that may solve your problem.

For some systems, such as the Dell T1600, reboot and acpi kernel options may not be effective, but one person was able to solve this same problem based on a recommendation to disable a BIOS feature:

"VT for Direct I/O"

One may also be able to upgrade the BIOS to enable reboot, but this is untested.


Is that an old machine?

Try modprobe apm before rebooting next time. APM is the thing used before ACPI came and this module may be able to do proper reboot via APM. If that modprobe helps you should add 'apm' to the list of modules to be loaded on boot (this is Linux-distribution-specific).

If it doesn't work the first time you could check modinfo apm and play with the module options.

  • Yes it's a little old machine but not very old. I tried "modprobe amp" which returned "FATAl: Error inserting apm (/lib/modules/2.6.26-2-686/kernel/arch/x86/kernel/apm.ko): No such device". Problem still persists.
    – Usman
    Mar 26, 2010 at 12:37
  • I don't have any HT (Hyper-threading) in my machine. The computer I am using is DELL Optplex 330 (2.8 GHz, 1 GB RAM)
    – Usman
    Mar 26, 2010 at 12:46
  • So it is not such an old machine that would have APM instead of ACPI. I guess it may be a broken ACPI then. That happens quite often (in one way or an other), unfortunately. Mar 26, 2010 at 14:55

I had this exact problem on some old IBM x86-64 Netburst Xeon architecture systems running Red Hat 3, 4 and 5.

When HT was enabled in the BIOS, init 6 would fail to reboot. With HT disabled, automatic reboot would work fine. I don't know if the problem is fixed now, but for a couple of years (while the servers performance was still relevant), it continued to be a problem.

  • I don't have any HT (Hyper-threading) in my machine. The computer I am using is DELL Optplex 330 (2.8 GHz, 1) GB RAM
    – Usman
    Mar 26, 2010 at 12:45

Check for mounted network dependencies - are there any NFS, CIFS shares or iSCSI, nbd, AoE targets initiated?

A funny workaround you may try is "kexec". The Debian package is fine. It will replace the actual reboot. Instead, the kernel image linked at /vmlinuz will replace the running kernel and boot. You will see no BIOS screen, no bootloader screen and it's way faster.


I faced the same problem with my new Intel D425 mini-ITX board.

I solved it by modifying ACPI Suspend State on BIOS configuration.

Final configuration: S1 state for ACPI S1 state indicator On

  • In my case, it's a intel minipc, I hope I checked BIOS earlier. There was a setting for system type, after setting it to Android, it reboot/poweroff without problem.
    – Ben
    Apr 9, 2021 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.