I've installed the certificate and set up the HTTPS bindings. However, when I load the site on HTTPS it does not load.

I've looked at all the settings but everything seems correct.

I've restarted the server numerous times. The certificate is stored on the local computer under Personal > Certificates. I have the private key for the certificate. The port (443) is open.

If I try https://localhost on the server, the site loads, but with a domain error (i.e., it's localhost and not example.net). But https://example.net doesn't load.

I really don't know why the HTTPS URL isn't loading.

  • What error do you get at thedomain.com? A timeout? A cert error? A 404? You say port 443 is open. Where is it open? – Ben Doom Mar 29 '10 at 0:49
  • I get a "Server not found" error. Port 443 is open for TCP under Firewall->Incoming Connections. – rksprst Mar 29 '10 at 2:34
  • If you do a netstat -an at a command prompt do you see a line for port 443 in the local address column? – MattB Mar 29 '10 at 13:44
  • 1
    It's listening on :443 ... but no ip address is specified (under the local address column). – rksprst Mar 30 '10 at 18:37
  • 1
    In my case the server was on AWS and the inbound traffic was not allowed on port 443. Hope this helps someone. – Anshuman Jasrotia Jun 2 '17 at 6:17

If you are getting "Server Not Found", that means that the client could not find the responsible server to serve your request. In your case, that's a HTTPS-based application. You also said that HTTP works but HTTPS fails.

Verify the following:
Go to Control Panel\System and Security\Windows Firewall\Allowed Programs Verify that you have "Secure World Wide Web Service (HTTPS)" and "Domain, Home/Work, and Public" both checked.

You also said that when you try https://example.net from the server itself, it fails. Try browsing the application from the server itself and run netstat -ano and check whether there is any activity happening on port 443.

  • It's listening on port 443. – rksprst Mar 30 '10 at 18:42
  • Checking "Secure World Wide Web Service (HTTPS)" worked for me. – Alyce Feb 14 '16 at 23:52

You need to ensure that example.net actually points to the server's IP. You can do this either with an nslookup or just plain old ping the machine. This is your most likely cause.

  • It does point to the IP... the regular http domain works fine. It's only the https that is not working. – rksprst Mar 29 '10 at 2:26
  • 1
    In that case, then you need to make sure that the port is actually open and accessible from the outside. Try: openssl s_client -connect host:port – sybreon Mar 29 '10 at 5:59
  • 1
    Tried it and got operation timed out for port 443... If I changed the port to 80 I get Connected)... – rksprst Mar 30 '10 at 18:41
  • 1
    Then you better check your IIS configuration to ensure that it there is a binding for the SSL. – sybreon Mar 31 '10 at 8:17
  • I had the same symptoms and it was a firewall blocking port 443 – firstTimeCaller Jun 16 '15 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.