Let me try to explain my current setup. I have one linux machine acting as DHCP and DNS (dhcpd3 and bind) in my network. This works fine, all computers I hook up to the network gets an IP address and proper DNS servers set. Let's call it

However, we also have a Windows Server 2003 Domain Controller in our network to which we add our Windows computers (running XP), let's call it I noticed that when I run 'nslookup' on one of the windows machines, it says that the primary DNS is This have not been much of a problem since:

  1. The Windows clients are stationary
  2. The Windows server in itself point out my real DHCP/DNS, since I can reach everything specified in it

However, this turns out to be a problem when we use Laptops. They connect to the domain here and gets a DNS server, but when the user travels or connect the computer from home, we hit a problem. They are connected to their internet, but their DNS is which they can't reach since they're at home and not at the office network. I solved this by removing the register key called "NameServer" with the value, but it gets set again whenever they logon to the domain the next time (when they get back to the office).

Can I somehow make the computers take whatever DNS server they are handed when connecting to the internet or a home network, instead of always trying to reach the Domain Controller?


Your problem is your laptops are getting their DNS settings from group policy rather than DHCP which is reset every time the connect to the domain - see Group Policy to Specify DNS Servers in DHCP Environment - Good or Bad? for a discussion on why it is a bad (or good) idea.

Just change your Group Policy (Comp Config/Admin Templates/Network/DNS Client) so that it doesn't set DNS, instead set it by DHCP. When the laptops leave your network they will be free to pick up appropriate DNS settings from a relevant DHCP server.

This won't effect your desktops as they are either statically assigned or will get the settings by DHCP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.