First off I am a novice at AD and DNS so please bear with me. This is my current situation:

I have one server which is a DC and DNS server (win2k3) - Machine 1. I have another machine which is trying to join this domain - Machine2. This machine is also a win2k3 server.

This is what I have done so far: I have setup DNS on the DC and its tcp/ip dns is pointing to itself. On machine2 I have set its dns to point to the dc. The DNS has been setup with a forward lookup zone with the same name as the domain (accdirect.com). I can ping machine1 from the machine2 by its FQDN and ip. I have set up forwarders on the DC for our ISP dns and can browse the internet on both machines. In the DNS mmc on the DC I can see a host (A) has been created for machine2.

The problem is I still cannot join the domain. When I try join the domain via my computer -> properties then it brings up the username/password box and after I go "ok" it says cannot find domain accdirect.com If I run this from machine2 dcdiag /s:accdirect.com /u:accdirect.com\admin /p:***** then I get the following: Performing initial setup: *** Warning: could not confirm the identity of this server in the directory versus the names returned by DNS servers. If there are problems accessing this directory server then you may need to check that this server is correctly registered with DNS [accdirect.com] Directory Binding Error 1722: Win32 Error 1722 This may limit some of the tests that can be performed. Done gathering initial info.

On the dc all dcdiag and netdiag results pass.

If anyone could help me I would really appreciate this! Sorry if any of my terminology is a bit off, I have only been doing this for two days.

thanks Peuge

  • EDIT: This might seem like a stupid question but here goes: The two servers are on public ip addresses in tcp/ip settings, as one of them is a webserver, they both on the same network though. Firstly is this a problem? And secondly if I change the ip addresses to something else then will the webserver seize to work? – Peuge Apr 1 '10 at 7:27
  • can you do a nslookup on the fqdn of the domain? – tony roth Feb 10 '11 at 17:00
  • as in nslookup xxx.accdirect.com xxx being the netbios name for the domain – tony roth Feb 10 '11 at 17:00
  • can you do a nslookup on the fqdn of the domain? – tony roth Feb 10 '11 at 17:00

I wonder if the problem is the primary DNS suffix is not set...It doesnt sound like you are using DHCP right now which when configured would apply the primary DNS suffix for you.

You said you are able to ping the DC using the FQDN... Are you able to ping it using the hostname only? (Ping Machine1)

When you right click on my computer and go to properties --> Click the "Computer Name" tab --> Click "Change" you should have an extra button labeled "More..". Here you are able to tell it the primary DNS suffix. In your example "Accdirect.com". Once that is set try joining the domain again.

  • Hey, Thanks for all the input. Tony: I am able to do a nslookup, with and without using the netbios name, and it return the same each time. Ashgarden: I already had changed the DNS suffix on machine1. Both machines have the same DNS suffix when doing an ipconfig /all I am able to ping each machine from the other machine using netbios and using FQDN, and both resolve to the correct IP Address. Any other suggestions much appreciated? Thanks – Peuge Apr 1 '10 at 7:19
  • Forgive me if this is wrong: I am trying to do a netdiag /test:dns on machine1 (not the DC) and the DNS test throws this error: [Warning] Cannot find a primary authoritive DNS server for the name 'machine1name.accdirect.com' I was thinking this could be the problem? – Peuge Apr 1 '10 at 8:46
  • In response to your edit from earlier... I would have the servers IP addresses be private IP's and use NAT on your firewall to forward traffic from your webservers public IP to it's internal Private IP. Is there a reason you assigned them both public IP's directly? – Jesse Paxson Apr 1 '10 at 15:48
  • Is it possible that the netdiag error is because of a dual nic? Maybe try disabling the secondary nic and run again...? – Jesse Paxson Apr 1 '10 at 16:25
  • I have tried disabling all other NIC's and still the same problem persists. With regards to public / private IP's: If I make the ip private (in tcp/ip settings) will the public ip still be available, i.e. Will our website still work, or do I need to setup something in routing and remote access? Thanks – Peuge Apr 6 '10 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy