I just launched my first IIS FTP site following many of the tutorials from IIS.NET... I'm using IIS Users and Permissions rather than anonymous and/or basic.

This is what I'm seeing while trying to establish the connection...

Status:    Resolving address of ftp.mydomain.com 
Status:    Connecting to ###.###.##.###:21... 
Status:    Connection established, waiting for welcome message... 
Response:  220 Microsoft FTP Service  
Command:   USER MyFTPUser  
Response:  331 Password required for MyFTPUser. 
Command:   PASS ********************  
Response:  530 User cannot log in. 
Error:     Critical error 
Error:     Could not connect to server
  • I've changed the PW to something so simple, I know that I'm not screwing up the UN and PW...
    – RSolberg
    Commented Apr 1, 2010 at 5:06
  • did you ever resolve this issue?
    – D3vtr0n
    Commented Apr 8, 2011 at 16:23

7 Answers 7


It's quite old but I found myself in the same situation. I solved giving the right permission to the "Network services" on some configurafiles:

CACLS “%SystemDrive%\Windows\System32\inetsrv\config” /G “Network Service”:R /E
CACLS “%SystemDrive%\Windows\System32\inetsrv\config\administration.config” /G “Network Service”:R /E
CACLS “%SystemDrive%\Windows\System32\inetsrv\config\redirection.config” /G “Network Service”:R /E

Hope it helps.


On Windows Server 2008 you must now use these commands:

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config" /Grant "Network Service":R /T

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config\administration.config" /Grant "Network Service":R

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config\redirection.config" /Grant "Network Service":R

in my situation, I was missing Role Service FTP extensibility, which is actually allows IIS Manager Auth. This is pretty tricky, as you could allow IIS Manager auth, but still it would not work until you have not installed FTP Extensibility


This worked for me on Windows Server 2012

ICACLS "C:\Windows\System32\inetsrv\config" /Grant *S-1-5-20:R /T
ICACLS "C:\Windows\System32\inetsrv\config\administration.config" /Grant *S-1-5-20:R
ICACLS "C:\Windows\System32\inetsrv\config\redirection.config" /Grant *S-1-5-20:R

Looks like you are not able to connect to the server. The issue is not related to password. I am not sure what you mean when you said "

using IIS Users and Permissions rather than anonymous and/or basic

You will need to implement some authentication either Anonymous or Basic. Follow this article and you should be good.


In my case, I created two user acccounts FTPUser and FTPAdmin in my local Windows machine. Actually when I created the same users in IIS it didn't work. But you've to create local Windows users using user accounts.


From: http://support.microsoft.com/kb/200475

This problem occurs when one of the following scenarios is true:

  • The Allow only anonymous connections security setting has been turned on in the Microsoft Management Console (MMC).

  • The username does not have the Log on locally permission in User Manager.

  • The username does not have the Access this computer from the network permission in User Manager.

  • The Domain Name was not specified together with the username (in the form of DOMAIN\username).

Do any of these apply?

Also as a side note I would recommend using SFTP instead of FTP - as you may know FTP transfers everything in cleartext (passwords included).

  • 2
    only applies to IIS 6 or lower...
    – RSolberg
    Commented Apr 2, 2010 at 2:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .