I have installed Management Services on IIS, and want to configure for Web Deploy.

At Server level I can see Mangagement Service, Feature Delegation, IIS Managers, etc

I also have IIS6 management installed, but as this is a production server I don't want to remove it just to check.

  • With Web Platform Installer, if you install the Web Deployment Tools 2.0, this will now be installed Out Of the Box.
    – Pure.Krome
    Apr 5, 2011 at 0:48
  • It is true now, but at the time there was something going on with intall where it wouldn't automatically "check the box"
    – Dan
    Apr 5, 2011 at 8:59

3 Answers 3


Answered it myself.

Used the Web Deployment Tool installer and clicked "Change" then added the IIS Management components.

Now I can set Web Deploy service delegations

  • That worked for me as well. Also be sure to restart IIS or it won't show up. Cheers! Sep 11, 2014 at 15:03
  • To find this download please see the more detailed explanation from fiat
    – Luke
    Feb 12, 2015 at 21:03

I used these steps for Windows Server 2008 R2.

  • Go to Web Deploy home page. The default download at time of writing doesn't allow change/remove/repair. Keep reading.
  • Click 'additional downloads', obtain the full offline msi for x86 or 64bit.
  • Run the installer
  • Remove the 'Management Service Delegation UI' feature
  • Finish Install
  • Reinstall 'Management Service Delegation UI' feature
  • Close and restart Server Manager

On one server, I had to go one level higher and remove, add 'IIS Deployment Handler' before I got the Delegation icon to appear in IIS. This may have been because I didn't follow the final step.

If the Web Deploy installer does not present the 'IIS Deployment Handler' option and child components, ensure that your web role has the 'management tools' option installed.

  • 2
    Holy cow, man! I have wasted 5 hours on that! Microsoft really sucks if it works this way. Thanks for your solution!!!
    – user337085
    Jul 28, 2014 at 11:19

In order to even see (it wasn't there at first!) the "IIS Deployment Handler" option in WebDeploy 3.5 x64 installer I had to do the following things:

1.Right click on Web Server and select "Add Role Service"

enter image description here

  1. Check "Management Service" and "IIS Management Scripts and Tools"

enter image description here

  1. After that "Management Service" icon appeared

enter image description here

  1. Then I had to launch WebDeploy 3.5 installer again and the new "IIS Deployment Handler" option appeared. I checked this option and installed it it.

enter image description here

  1. And only after that the "Management Service Delegation" icon finally appeared

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.