I've got an Xserve where I've configured a Drobo Pro. Connected via firewire and USB, it works fine, but when connected to a separate network port, it doesn't mount. I've got the Drobo Pro configured to and the network port to I can ping the IP of the Drobo Pro just fine. I've installed Drobo Dashboard 1.6.8.



  • I should add that I've restarted the server and Drobo Pro many times. They are connected directly with a network cable, not via a switch, and I've replaced the network cable twice. No firewall is enabled, and I've tried alternate network ports (the computer has 6) – niklassaers Apr 2 '10 at 18:46
  • 5
    Minor nit: IANA allocated this past September. You might want to look at renumbering. :) – Gerald Combs Apr 5 '10 at 19:05
  • 1
    Not to mention it's faux pas to use non-private ranges, even if they are unallocated. – Chris S Jul 28 '10 at 0:14

Maybe this is obvious, but you didn't mention anything about an iSCSI initiator on the Xserve. You need an iSCSI initiator in order to mount the block device. From there, it will look like any other physical disk you've plugged into your mac.

I use globalSAN but there is also one from ATTO and Small Tree.

| improve this answer | |
  • Thanks for the tips, I thought I was using the iSCSI initiator that was delivered with the Drobo Pro. After reinstalling an old version from the CD and then upgrading (instead of installing directly from the downloaded version), they connected. However, I'm still having trouble, so thanks for the tips, I'll try out these three iSCSI initiators as well. :-) – niklassaers Apr 7 '10 at 13:39

The DroboPro can only have one connection at a time so if you want to use the iSCSI connection you need to disconnect the Fireware and USB connections.

| improve this answer | |
  • Ugh. Really? That seems awfully shortsighted of the manufacturers. That said, I do hear a lot of bad things about the Drobo devices, such as their slow transfer rates. – Tom O'Connor Apr 6 '10 at 23:27
  • The transfer rates are quite fine for my work, 20-80MB/sec depending on the connection – niklassaers Apr 7 '10 at 13:38

I have my DroboPro on an ethernet network at home.

When I configured my macbook pro to use iscsi with the drobo pro it worked fine.

On the same network (also used for ethernet) I have an imac on which I also installed the drobo dashboard for redundancy.

I know I can only access the drobo pro from one computer at a time over iscsi, but how do I select which computer connects?

The last computer configured ( as a back up access the imac) always seems to grab the drobo pro, if it is not switched on i can get access from my mac book pro. Can I manually select which?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.