I build a basic WCF service that I now want to host in IIS7 under Windows Server 2008 R2.

I added the service as an application under the default web site but whenever i try to run the application I get the following error:

HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

Config Error - Cannot read configuration file due to insufficient permissions

The only way I can get this service working is if i choose to "connect as" the server Administrator when adding the service. the "application user (pass-through authentication)" option does not seem to work.

Could anyone help me out, I've just started using IIS7 and have no idea what to do... Thanks


Its a permissions issue, and its a two fold problem you need to solve (depending on what your goals are).

  1. You need to determine if this site should be anonomous, or if you want a password. 1a. If you want authentication, you need to determine if you want it to be integrated or basic. If you go with basic, you'll want an SSL cert. if you go with integrated, bear in mind by default NTLM is limited to a single hop for authentication. So if you need the user logging into, to access a remote file share or a SQL server (authenticating as themselves not as the app pool), you'll need kerberos (which has its own level of complications)

  2. You need to make sure your NTFS permissions are setup for the directory your pointing IIS at.


IIS should have given you good error message on where the issue is. If you are still finding it difficult to trace the error refer the blog Troubleshooting HTTP 500.19 Errors in IIS 7


well, you could start by checking what permissions your directory and files have and then adding what is needed. On a default 2008 r2 install Users group has read and list permission under inetpub, so that definitely works, although it's probably not that secure.

  • Same problem here looking at test IIS7 on Windows 2008 R2. You're right that the local Users group has read permissions and equally that it doesn't sound too secure – Rob Nicholson Oct 28 '10 at 21:23

For the site you've set up, go to Authentication and choose the Edit action for Anonymous Authentication. The identity will be either a specific user or the application pool identity - whichever one is set up will tell you what user you need to grant filesystem access to the directory where you've hosted your WCF service.


you could try:

IIS->Sites->(DefaultWebSite or your Site)->Feature View->Double Click Error Pages->Edit Feature Settings -> select Detailed Errors -> press OK.

else there is a post abour debugging WCF Services here: Detailed Errors not working for WCF Service in IIS

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.