I have web site on IIS 7 on Windows 2008, when I try to access the "page" (that correctly bound to namespace in web.config) I get error: "The required page cannot be accessed because the related configuration data for the page is invalid".

Very important to say that on windows 7 I have this working.

May be this is because I don't see ASP.NET area in management window? If yes, can yo tell me how I install ASP.NET on IIS 7 on windows 2008?

Thank you for ahead.


You are right. The .ashx is part of HandlerFactory which is installed when you select ASP.NET in the Web Server Role Services.

To enable ASP.NET in Windows 7 and Windows Server 2008

In Windows 7, you can enable ASP.NET from Control Panel -> Programs -> Programs and Features -> Turn Windows features on or off. Expand Internet Information Services -> World Wide Web Services -> Application Development Features and click ASP.NET.

In Windows Server 2008, Open Server Manager -> click Roles -> click Add Roles -> select Web Server (IIS) -> in Role Services click ASP.NET it will prompt for necessary dependent Roles Services click Add Required Role Services.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.