3

How can I disable TLS in postfix? I have problems sending email to a specific host, they said I should disable TLS as I am not using it. Emails are not arriving to indamail.hu ever.

Apr  6 16:21:15 server postfix/smtp[12059]: < mail13.indamail.hu[91.83.45.53]: 220 mail13.indamail.hu ESMTP
Apr  6 16:21:15 server postfix/smtp[12059]: > mail13.indamail.hu[91.83.45.53]: EHLO server.xxx.hu
Apr  6 16:21:15 server postfix/smtp[12059]: < mail13.indamail.hu[91.83.45.53]: 250-mail13.indamail.hu
Apr  6 16:21:15 server postfix/smtp[12059]: < mail13.indamail.hu[91.83.45.53]: 250-STARTTLS
Apr  6 16:21:15 server postfix/smtp[12059]: < mail13.indamail.hu[91.83.45.53]: 250-PIPELINING
Apr  6 16:21:15 server postfix/smtp[12059]: < mail13.indamail.hu[91.83.45.53]: 250-8BITMIME
Apr  6 16:21:15 server postfix/smtp[12059]: < mail13.indamail.hu[91.83.45.53]: 250-SIZE 10485760
Apr  6 16:21:15 server postfix/smtp[12059]: < mail13.indamail.hu[91.83.45.53]: 250 AUTH LOGIN PLAIN CRAM-MD5
Apr  6 16:21:15 server postfix/smtp[12059]: > mail13.indamail.hu[91.83.45.53]: MAIL FROM:<info@xxx.hu> SIZE=2365 BODY=8BITMIME
Apr  6 16:21:15 server postfix/smtp[12059]: > mail13.indamail.hu[91.83.45.53]: RCPT TO:<ccc@indamail.hu>
Apr  6 16:21:15 server postfix/smtp[12059]: > mail13.indamail.hu[91.83.45.53]: DATA
Apr  6 16:21:15 server postfix/smtp[12059]: send attr reason = lost connection with mail13.indamail.hu[91.83.45.53] while sending MAIL FROM
Apr  6 16:21:15 server postfix/smtp[12059]: 70B132188649: to=<ccc@indamail.hu>, relay=mail13.indamail.hu[91.83.45.53]:25, delay=163321, delays=163319/0.02/1.4/0.04, dsn=4.4.2, status=deferred (lost connection with mail13.indamail.hu[91.83.45.53] while sending MAIL FROM)

main.cf contains

smtp_use_tls = no
smtpd_use_tls = no
3

Check your main.cf for smtp_tls_security_level or smtpd_tls_security_level.

  • Added both smtp_tls_security_level = none smtpd_tls_security_level = none but I still see Apr 6 17:14:26 server postfix/smtp[17820]: < mail15.indamail.hu[91.83.45.55]: 250-STARTTLS – Hamlet Apr 6 '10 at 15:18
  • 1
    This is the announcement of mail15.indamail.hu that it supports connection upgrades with STARTTLS. The point is that your MTA doesn't issue STARTTLS and thus just uses a plain-text connection. – joschi Apr 7 '10 at 5:37
  • Your log says you were disconnected while trying to send mail (i.e. at MAIL FROM:) stage. To get a clearer picture, you will need more information from the recipient mail server (hopefully a sample log entry.) They seem to be interpreting the error as caused by TLS, but may be something else in their smtpd_sender_restrictions, possibly something like DNS reverse PTR? – samt Jul 12 '11 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy