The basic problem is we have a FC6 server instance running on a virtual machine, and the system time seems to have been slowly varying until it is now causing a problem. The server runs 24/7 and has been up for 155 days.

It has been changed to show GMT, and reports the time as (example) 00:15:15 GMT whereas the actual time is 00:00:00 GMT. This is an offset of 915 seconds.

selinux has been changed to 'setenforce 0' for testing and I am running as root.

I stop the ntpd service and change the time in System|Administration|Date & Time. The time still shows the same with 'date' in bash. There are no error logs.

I change the date with 'date --set' in bash. The response confirms the changed date. I run 'date' and the incorrect date is shown. There are no error logs.

I start the ntpd service and /var/log/messages shows success with 'time reset -915.720139s'. The date remains unchanged.

ntpq -p shows three three time servers all have offsets of around -915 seconds.

I stop ntpd service and try 'ntpd -gqx' and get the same result as above - success, but a large negative time reset.

I've tried varying combinations of the above, and a few more settings in System|Administration|Date & Time - no change. I just need to reset the system time to GMT. No offset. But I can't wait for ntpd to slew the time over the next few weeks.

Any advice is welcome, cheers! Surely this shouldn't be this difficult...


  • I think I might have it - it's running in a VM (I don't know which) and there are issues with changing dates, syncing with the host, and using ntpd at all. I'll have to leave it to our Sysadmin.
    – Mark White
    Apr 8 '10 at 8:50
  • My advice? Upgrade to something that isn't so ancient. CentOS 5 should do you fine. Apr 8 '10 at 13:23

Yeah, it's a pig isn't it really.

It's a legacy thing. The fun I've had developing on a local rig and then uploading for testing. PHP5.1, unable to upgrade because newer versions aren't supported, compiling plugins for json and mcrypyt, selinux stomping all over everything. Loads of other piddly stuff to correct. Oh how I've laughed.

Oh well - I brushed up my very limited Linux skills.


Mark, as you correctly point out, it's a problem of vmware setting.

Either disable the "sinchronize with host" vmware setting (can be made when the vm is turned off), or configure correctly ntp on vmware.

I had some issues with ntp on vmware, my suggestion is to configure correctly ntp on vmware AND disable "sinchronize with host" setting, leaving ntp to do its job both on vmware and virtual machines.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.