3

I saved the following file at /etc/init/nodejs.conf

description "node.js server"
author      "dorelal"

start on startup
stop on shutdown

script
    # We found $HOME is needed. Without it, we ran into problems
    export HOME="/root"

    exec /usr/local/bin/node /home/dorelal/nodejs.js 2>&1 >> /var/log/node.log
end script

Then I tried to start the server

> sudo initctl start nodejs
initctl: Unknown job: nodejs

Ubuntu information

> cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"

What do I need to do to start the server using upstart.

  • did you try restarting init? – kbyrd Apr 9 '10 at 5:06
2

I had a similar problem which was solved by running initctl reload-configuration manually (it's supposed to watch the file but I assume since it's a symlink that it has problems).

| improve this answer | |
0

For some reason, I have the idea that the comment section is required at the top of the file. Look at one of the other files in that directory and copy that format into your file (making changes as necessary) and see if that doesn't help (also, verify that the file owner, group and permissions are correct).

| improve this answer | |
0

I have found that the comments at the top did not affect whether it worked or not.

What affected it was putting quotes around the description, in my particular case.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.