Installed Solr on my Windows XP PC. Tomcat seems to be working fine. Cannot get Solr to work. I noticed the TrieDateField is declared in a file called schema.xml in the SolrHome directory. Any thoughts?

The Url http://localhost:8080/solr/ returns:

HTTP Status 500 - Severe errors in solr configuration. Check your log files for more detailed information on what may be wrong. If you want solr to continue after configuration errors, change: false in null ------------------------------------------------------------- org.apache.solr.common.SolrException: Unknown fieldtype 'date' specified on field updated

Here is an excerpt from the catalina log file:

SEVERE: org.apache.solr.common.SolrException: Error loading class 'solr.TrieDateField'
    at org.apache.solr.core.SolrResourceLoader.findClass(SolrResourceLoader.java:273)

Caused by: java.lang.ClassNotFoundException: solr.TrieDateField

Encountered the same issue, after some digging I tried the following and it worked:

In your schema.xml file, change the class from "solr.TrieDateField" to "org.apache.solr.schema.TrieDateField".


<fieldType name="date" class="org.apache.solr.schema.TrieDateField" omitNorms="true" precisionStep="0" positionIncrementGap="0"/>

I noticed this because of this comment in the file:

<!-- Class names starting with "solr" refer to java classes in the
   org.apache.solr.analysis package.

Which is not where the TrieDateField class is located.

Hope this helps. -C

| improve this answer | |
  • Thanks, I honest don't remember what my solution ultimately was, but this helps. – James Lawruk Aug 31 '11 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.