I am attempting to configure an IBM 8275-416 switch (I found a manual here) via serial connection. However, when I connect with HyperTerminal, the output contains a lot of garbage characters. It's pretty much unusable, because there's enough layout-breaking text-gunk that it's very difficult to determine what's actually being displayed.

Screenshot http://stronglyemergent.com/wp-content/uploads/hyperterminal.png.

I was able to reset the switch to factory defaults via the terminal interface, so I know that it's not entirely broken. It also performs basic functions all right (i.e., you plug in clients and Ethernet cables -> they can connect to clients plugged into other ports) - but I'd like it to do more than that (VLANs yay). I don't know if its in-band UI is operational or not, because I can't get the terminal interface to behave well enough to properly turn on the web/SNMP UI. So that's not available.

Things I've tried:
- Changing the encoding: HyperTerminal lets me choose between Standard JIS and Shift-JIS. Neither setting fixes the issue.
- Checking emulation settings: The manual demands VT100, 19200 baud, 8 data bits, and such: I have faithfully applied these settings, both in HyperTerminal's settings and in the properties of the COM1 port in Device Manager (connecting from a Windows machine).
- Restoring to factory defaults: See above.

Things that it could be, but that seem unlikely:
- Cabling: Couldn't find a proper null-modem cable, so used two 232-to-RJ45 adapters. But if it was a problem with the cable, wouldn't it be more likely to not connect or do input at all, rather than just garble the text? Since I was actually able to perform the reset-to-factory defaults operation, I don't think it's this.
- Device as a whole broken: It is a decade and change old, so it's possible that it's just dying slowly. Again, though, it seems like there would be more symptoms than just garbled text in the terminal.

What else can I try to get a sane interface to this switch?


Do the terminal settings in the IBM manual (the link is dead for me) request hardware flow control (you mention speed and data bits but not flow control in the question)? I ask because I believe some of the "RS232-to-RJ45" tie the RTS and CTS signals together internally and therefore would not allow proper device to device RTS/CTS hardware flow control.

  • The settings in the manual only say "flow control: none," and the HyperTerminal setting is also "none." That sounds like a promising line of inquiry, though. If the adapters were the problem, would a proper double-female RS232 cable solve the problem? – Brighid McDonnell Apr 15 '10 at 22:43
  • If it is supposed to use no flow control then the adapters are probably fine. But it probably wouldn't hurt to see if you can find a regular null modem female-female RS232 cable to verify the same behavior. – Thomas G Apr 16 '10 at 15:53

It was probably something with the COM port: the kludge of USB-serial device to adapter to adapter worked just fine for telnetting into the switch and doing configuration. If I can dig up a proper female-female RS232 cable, I'll try again with that, but for now it's working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.