This can be a DNS cache issue from my local machine, but I am not sure. This is what happens. I have a domain that does not use wildcard subdomains, so they have to be created.

Without creating the domain, and I point my browser to test.domain.com, I get a page server not found. Now when I create the subdomain, I keep getting the same problem.

Now when I first create the domain, without ever visiting the page, I get the normal page, but now when I delete the subdomain, it never goes away.

Can this be a DNS cache issue, I am working on a shared environment, maybe the router has a cache but I doubt that. Can this have something to do with my setup.

I have tried to use the Google DNS hosting, but this gives me the same results.

I have also tried some tools that clear my local DNS cache, they were some add-ons for FireFox.

Anyone have any ideas what can be the problem. Are there any tests I can do to see if there is some kind of cache between me and the server.


How long did you wait before making the DNS change and testing it? Most DNS entries are cached for a minimum of 30 minutes (did you see a Time to Live, or TTL setting when creating your subdomain? Thats the number of seconds that the record will be cached for).

This is the minimum time you'll have to wait before the correct record will show up (it's meant to be the maximum time, but isn't for the following reasons). Badly behaved DNS servers (of which there are a lot) will totally ignore your advertised TTL and cache it for as long as they like.

A fairly good way of knowing if the change has taken place is to use your favourite nslookup tool. When you're in nslookup, query:

test.example.com nsX.dnsserver.com

(replace test.example.com with your real domain, and nsX.dnsserver.com with the address of a nameserver your domain uses).

Note that that method is not always 100% accurate, as some DNS providers will respond to ANY domain request, but if you visit the address you just get a parking page.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.