I want to use directadmin as my web control panel and it needs several packages like g++ , gcc and etc...

as usuall I started to type apt-get install g++ and there problems start :

dependecy error...

then I tried to apt-get -f install and I got this error

(Reading database ... 15140 files and directories currently installed.) Removing libc6-xen ... ldconfig: /etc/ld.so.conf.d/libc6-xen.conf:6: hwcap index 0 already defined as nosegneg dpkg: error processing libc6-xen (--remove): subprocess post-removal script returned error exit status 1 Errors were encountered while processing: libc6-xen E: Sub-process /usr/bin/dpkg returned an error code (1)

what shoud I do? I want to install g++ and all of its dependencies due to using of directadmin I need it.


closed as off-topic by HopelessN00b Apr 3 '15 at 17:01

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

apt-get update
dpkg --configure -a
apt-get install libc6-xen
apt-get -f install

You have some partially installed packages and it is trying to remove libc6-xen. If this is a xen vps, that is probably a rather fatal issue. The above should get you back to a workable state.

Once you get things back to a reasonable state with that, try:

apt-get install libc6-xen g++

Don't proceed. It will probably tell you that it needs to remove something due to some dependency. Simplest solution is probably to run:

apt-get -f -u upgrade

and possibly

apt-get -f -u dist-upgrade

to get the machine to a clean state, then, try installing g++. Watch the messages very carefully as it probably tried to install g++ and said it was going to remove something -- probably libc6-xen. It might have said something like: removing libc6-xen, no available packages.

Get your machine's dependencies fixed, then post the text from:

apt-get install libc6-xen g++
  • hi , thanks for your advice I've done what u said here and here is the result of executing apt-get install libc6-xen g++ : (I will post it in next comment) – Seyed Vahid Hashemi Apr 18 '10 at 20:42
  • Reading package lists... Done Building dependency tree... Done You might want to run `apt-get -f install' to correct these: The following packages have unmet dependencies: g++: Depends: cpp (>= 4:4.4.2-3) but it is not going to be installed Depends: gcc (>= 4:4.4.2-3) but it is not going to be installed Depends: g++-4.4 (>= 4.4.2-1) but it is not going to be installed Depends: gcc-4.4 (>= 4.4.2-1) but it is not going to be installed locales: Depends: glibc-2.7-1 E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). – Seyed Vahid Hashemi Apr 18 '10 at 20:44
  • and yes I have vps which is created by xen , so is it possible for me to isntall these packages??? i mean g++ gcc and so no? regards. – Seyed Vahid Hashemi Apr 18 '10 at 20:45
  • does apt-get -f install finish? if not, do dpkg --purge g++ then run apt-get -f install. Once that finishes, you should be able to upgrade and figure out why your dependencies cannot be installed. Something has gone wrong somewhere with your installation -- getting it to a working state and then figuring out what went wrong is the next step. I don't see any reason why you can't, but, it might be that you have something held, preventing g++ from being installed. Get the machine to a clean state, then, post what happens when you try to install g++ – deleted Apr 18 '10 at 21:46
  • hi,I solve it , this is a known bug in kernel I've read about that in a mailing-list and it was indicated as bug #518133 there is a config file called libc6-xen.conf inside /etc/ld.so.conf.d/ and value of that should be 0 not 1. – Seyed Vahid Hashemi Apr 20 '10 at 8:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.