I have a client that has an IBM xSeries 345 eServer. Per the IBM support website, I have downloaded the ServerGuide Setup 7.4.17 installation ISO and burned a bootable CD. The CD boots fine and loads the utility. I walk through the following screens without any issue:

  1. Set the date and Time
  2. Detect the IBM ServeRAID card and install the latest firmware
  3. Clear the hard disks
  4. Set up the RAID array

The next step is format the NOS partition. I select my partition size and the utility goes through the following steps:

  1. Creating NOS partition
  2. Formatting NOS partition (NTFS)
  3. Copying W32 files

The copying W32 files takes about 10 minutes. I see the CD drive and disks working hard. When the copying is complete, I'm taken to a blank page just NOS Partitioning at the top. At the bottom of the screen are the familiar Back and Exit buttons. I see the place where the Next button should be, and if I click on it I can tell there is something there, but the space is empty. No button is displayed and clicking the empty spot doesn't ever take me to the next screen.

I can't load the OS until I get past this part. I have already tried:

  1. Burning multiple copies and versions of the ServerGuide CD
  2. Letting the final screen just sit there over the weekend thinking it might advance after syncing the drives or something

Has anybody else seen this? I'm really at a loss here.

EDIT: I found another person who has the exact same problem as me: http://www.ibm.com/developerworks/forums/thread.jspa?messageID=14451763

  • Was the source Windows disc created using an original microsoft ISO file? I always found that if you were using something made with nlite or was slip-streamed that this would fail. – SpacemanSpiff Jul 3 '12 at 5:07

I just had problems setting up an IBM x346 server 2 days ago so perhaps my experience will be helpful.

I found the 2 key elements to do were:

1) Upgrade the server bios (there are downloadable files on IBM's site - including one that works off a CD since getting a boot floppy is hard work these days :-) )

2) If your machine has an IBM RAID controller, also update the BIOS on it.

I did both of these things and after that it worked like a charm.

Mind you, I was installing Win7 Pro (!) which worked, much to my amazement.

Good luck.


Can you run just the Windows installer, without using their setup CD? You might need to put it in for the drivers, but try to see if you can just get an OS on there normally.

  • Windows CD won't boot. I've tried 3 different discs that I know work. At first I thought I had a CD Drive problem, but all of the ServerGuide CDs boot just fine. I was also able to boot off a ServeRAID disc this afternoon without any problem. – Kyle Noland Apr 19 '10 at 21:23
  • 1
    You may have a hardware problem if Windows won't boot and the ServerGuide won't run properly. Can you try other installs, like Linux? There's plenty of LiveCD Linux distros that don't require installation to the harddrive, and then you could run some exhaustive hardware diagnostics. Actually, IBM has a hardware diagnostics package that you can run under an OS or on its own bootable media : www-947.ibm.com/systems/support/supportsite.wss/… – mfinni Apr 21 '10 at 17:30

Have you tried booting from the Windows installation from a USB stick instead of a CD?

I use rufus for putting the OS there. Try googling around for some tutorials how to do that, it usually takes a few times to get to the "bootable" config - the partition format is tricky, I suggest the MBR for BIOS computers options first.

Perhaps that could help you boot up as well :)


Likely a disk or RAM problem.

I would suspect the RAM first. Live-boot off of a CD w/ MemTest86. Or pop the case. Swap the first and last DIMM. Try the OS installation again. (Follow all vendor guidelines for working on a server's internals)

For disk-issues, I'd recommend using the analysis tools to test the array's drives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.