9

I have a LDAP server and a predefined shell (bash) set in it. But there are some machine on which I want a different shell to be used whenever user login to that instead of the shell stored in LDAP.

How can I do this?? Can someone give me some direction in this?

Thank you

  • which os/version? – rkthkr Apr 20 '10 at 6:22
  • OS - Debian Lenny – Incredible Apr 21 '10 at 9:34
10

In /etc/ldap.conf add the following line:

nss_override_attribute_value loginShell <different_shell>

Best of luck,
João Miguel Neves

  • 1
    Just a note that for this to work for me, I had to restart nscd after the change (/etc/init.d/nscd restart) – Michael Mior Dec 21 '13 at 2:47
  • /etc/ldap.conf is libnss' configuration file. On debianish systems, it is /etc/libnss-ldap.conf. man nss_ldap on your system should give the exact name. I also had to run nscd -i passwd to flush nscd cache. – exore Sep 23 '19 at 2:42
3

Shared home directories? If not, put into the users ~/.bash_profile (or whatever is the proper file, check INVOCATION in man bash):

exec /bin/tcsh

Or whatever shell you wish to replace bash with.

If they login using ssh, then you could use keypairs and forced commands.

Please note, depending where you place the exec for another shell, commands like scp may not function properly if you do not check for an interactive shell, like in the /etc/skel/.bashrc on Ubuntu.

Your best bet is to kindly ask your LDAP admin to change the loginShell for your LDAP user.

  • Users will be login through ssh. Can you please elaborate a bit more on the use of keypairs and forced commands option. Can you please give me some pointers? Thank you. – Incredible Apr 21 '10 at 9:36
  • SSH keypairs: <sial.org/howto/openssh/publickey-auth> Information about forced commands can be found on the man pages sshd(8) and sshd_config(5) – ptman Apr 21 '10 at 12:32
  • I couldn't find an option that automatically does it for all users. It should be something related to ldap as well, because here sshd will read the default shell from ldap. And I want to override that. – Incredible Apr 24 '10 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.