1

When trying to extract the Glassfish jar file with

java -Xmx256m -jar glassfish-installer-v2.1-b60e-linux.jar

i get following error:

(.:31766): Gtk-WARNING **: cannot open display:

and extraction doesn't happen. It somehow assumes i'm on an real machine rather on a SSH shell. How can i solve this?

1

You can append -console to the command:

java -Xmx256m -jar glassfish-installer-v2.1-b60e-linux.jar -console
  • THANKS (big thanks) - that did the trick. Why is java assuming i'm on an X11 machine? – whlk Apr 21 '10 at 9:22
  • Java isn't assuming, but the glassfish installer is assuming that. Can I pimp for an upvote? ;) – tronda Apr 21 '10 at 10:30
  • "Vote Up requires 15 reputation (click on this box to dismiss)" sorry bro – whlk Apr 21 '10 at 10:38
  • nope, doesnt give me any points – whlk Apr 21 '10 at 11:53
1

Can you use an ssh tunnel?

ssh -X my.host

You may also need to enable ssh forwarding in /etc/ssh/sshd_config

Another option might be just do unset DISPLAY and see if that works.

  • neither of this options worked for me. – whlk Apr 20 '10 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.