I have successfully installed OpenManage on a CentOS 5.4 server and I'm able to use OpenManage through the web interface running on port 1311, but I would like to be able to expose this information through the SNMP server. I don't know SNMP particularly well so the configuration is a result of trial and error.

I've tried to follow the description pointed out in the Open Manage Server Administrator User Guide. I've followed the documentation regarding SNMP configuration, but without success.

I've created a small snmpd.conf file:

com2sec notConfigUser default public
group notConfigGroup v1 notConfigUser
group notConfigGroup v2c notConfigUser
view systemview included .
view systemview included .
access notConfigGroup "" any noauth exact all all none
view all included .1
rwcommunity public
syslocation "Somewhere"
syscontact adm@test.com
pass . /usr/bin/ucd5820stat
smuxpeer .

When I try to fetch SNMP information by using snmpwalk I get the following output:

SNMPv2-MIB::sysDescr.0 = STRING: Linux myserver.test.com 2.6.18-164.15.1.el5 #1
SMP Wed Mar 17 11:30:06 EDT 2010 x86_64
SNMPv2-MIB::sysObjectID.0 = OID: NET-SNMP-MIB::netSnmpAgentOIDs.10
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (1180389) 3:16:43.89
SNMPv2-MIB::sysContact.0 = STRING: adm@test.com
SNMPv2-MIB::sysName.0 = STRING: myserver.test.com
SNMPv2-MIB::sysLocation.0 = STRING: "Somewhere"
SNMPv2-MIB::sysORLastChange.0 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORID.1 = OID: SNMPv2-MIB::snmpMIB
SNMPv2-MIB::sysORID.3 = OID: IP-MIB::ip
SNMPv2-MIB::sysORID.6 = OID: SNMP-FRAMEWORK-MIB::snmpFrameworkMIBCompliance
SNMPv2-MIB::sysORID.7 = OID: SNMP-MPD-MIB::snmpMPDCompliance
SNMPv2-MIB::sysORDescr.1 = STRING: The MIB module for SNMPv2 entities
SNMPv2-MIB::sysORDescr.2 = STRING: The MIB module for managing TCP implementations
SNMPv2-MIB::sysORDescr.3 = STRING: The MIB module for managing IP and ICMP implementations
SNMPv2-MIB::sysORDescr.4 = STRING: The MIB module for managing UDP implementations
SNMPv2-MIB::sysORDescr.5 = STRING: View-based Access Control Model for SNMP.
SNMPv2-MIB::sysORDescr.6 = STRING: The SNMP Management Architecture MIB.
SNMPv2-MIB::sysORDescr.7 = STRING: The MIB for Message Processing and Dispatching.
SNMPv2-MIB::sysORDescr.8 = STRING: The management information definitions for the SNMP User-based Security Model.
SNMPv2-MIB::sysORUpTime.1 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.2 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.3 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.4 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.5 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.6 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.7 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.8 = Timeticks: (0) 0:00:00.00

I suspect that I should get some DELL specific information when I use the snmpwalk utility. Is there a configuration in snmpd.conf file which is wrong, or do I have to configure on the OpenManage side in order to get the hardware information accessible from SNMP?

Update: Could mib files help me interpret the information returned from snmpwalk? I see that several mib files is located under /opt/dell/srvadmin/.

Update 2: I've verified that the SNMP daemon doesn't return any of Dell OIDs which means that either the snmpd.conf file is wrong or else there's some OpenManage configuration which is missing.


Here's a setup which now works

  1. Install the repository

    wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash

  2. Install the required software

    yum install net-snmp OpenIPMI srvadmin-all

  3. Configure SNMP:

Here how our current snmpd.conf file look like

\# DELL Stuff
\# sec.name source community
com2sec notConfigUser default public

\# groupName securityModel securityName
group notConfigGroup v1 notConfigUser
group notConfigGroup v2c notConfigUser

\# Make at least snmpwalk -v 1 localhost -c public system fast again.
\# name incl/excl subtree mask(optional)
view all included .1
view systemview included .
view systemview included .

\# group context sec.model sec.level prefix read write notif
access notConfigGroup "" any noauth exact all none none

\# Added for support of bcm5820 cards.
pass . /usr/bin/ucd5820stat

\# Allow Systems Management Data Engine SNMP to connect to snmpd using SMUX
smuxpeer .

As far as I can tell this will be private MIB information, and because of that you will need to compile the MIB-file on both the client (monitored machine) and the server (monitoring machine).

The output you got didn't look entirely weird to me, you probably tried walking the "top" of the tree, so you got all it's "branches" of information at the same time. As far as DELL-specific information goes... don't get your hopes up too much, I've been disappointed a couple times as well while looking for SNMP information. All too often there just isn't any useful information to be fetched.

Good luck!


We use the following commands to get the dell mib entries installed by OMSA into snmpd:

find /opt/dell/ -name \*.mib -exec cp {} /usr/share/snmp/mibs \;
echo "mibs +MIB-Dell-10892:StorageManagement-MIB" >> /etc/snmp/snmp.conf 
  • Could you explain what happens when all that is present in the snmp.conbf file is that single line. Does the text ":StorageManagement-MIB" restrict part of the "SNMP-tree" which is exposed? I see that the following mib files got copied into the /usr/share/snmp/mibs directory: 10892.mib, dcs3fru.mib, dcs3rmt.mib, dcstorag.mib – tronda Apr 21 '10 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.