I am having a weird intermittent issue for only some users. I have a logon script that maps shared drives and issues a diisclaimer everytime the user logs on to a machine. The problem lately is that the logon script will not run for the user so we get a help desk call. When one of the help desk techs log on to the machine the script then comes up. The tech then logs off and the user will log back in and they will get the logon script. I am at wits end with this issue. Any help would be appreciated. It has happend on both Windows XP and Vista 64.

Sorry, The user is on the same wire as the DC and they are not at a remote site. They are using a Windows Vista 64bit machine to log into the domain. We do allow cahed credential logins. I have two users that have the same issue one is on a Windows XP and one on Windows Vista 64bit.

Here is a breakdown of exactly what happens: 1. The user logs into thier machine and they notice that none of thier drives are mapped. 2. THey call the helpdesk. 3. A technicain with Domain Admin rights uses the SET command to identify which domain controller is authinticating the user. 4. The technician then logs the user out and logs back into the machine and typed the SET command to check the domain controller that is authentication the user. It is the same domain controller as before.The login scrip workes fine and maps the drives. 5. The user is then asked to log into the machine and walla the scrip runs fine.

  • Pretty vague description there. Is the user on the same physical wire as the DC? Are they at a remote site? Are they using a laptop? Wifi? VPN? Do you allow cached credential logins? – Izzy Apr 20 '10 at 13:53

Another troubleshooting step to try is run the script manually as the user. You'll have to dig the file out of the GPO itself, but it'll let you know if for some reason whatever scripting language you used is somehow disabled for that user.


have you tried taking the machines out of the domain and then putting them back in? if it is only a few users, it shouldn't take long. I've had issues like this before, and it solved my problem.

  • I actually re-imaged a brand new computer and have had the same issue with the same user. I am wondering if it has something to do with a users profile. – tareq838 Apr 20 '10 at 15:11

Check the user's permitted logon hours in AD. I once had a user who had the same problem due to the fact that for some reason they had their logon hours set to odd times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.