I am testing DPM 2010 with Exchange 2010. I am attempting to restore a single mailbox from a previous backup to a Recovery Database. I created and mounting the Recovery Database on the Exchange 2010 server and set the overwrite property. When I run the restore for the mailbox and point it to the recovery databse I get the following error.

The recovery jobs for Exchange Mailbox Database MailboxDatabase01 that started at with the destination of EXCHANGE2010.domain.com, have completed. Most or all jobs failed to recover the requested data. (ID 3111)

DPM encountered an error while performaing an operation for E:\DatabaseFiles\MailboxDatabase01.edb on EXCHANGE2010.domain.com (ID 2033 Details: The process cannot access the file because it is being used by another process (0x80070020))

MailboxDatabase01 is one of our MDBs and not the RDB I setup for the recovery. I am confused why it is even trying to access this as I have triple checked that the recovery is pointed to the RDB.

Any idea what I am doing wrong?

  • 2
    I can't find the post right now, but MS basically admitted that was broke in the Beta, so I'd guess they haven't fixed it for the RC yet. Half of the issue is that it's so rare to want to restore a single mailbox (as admins almost always config Exch to not delete items for 30+ days, and that's enough for most situations). I'm not defending this as a valid reason for the feature being broke, but that was how the discussion went. – Chris S Apr 26 '10 at 12:59
  • Chris S: this is a legitimate (and likely correct) answer. Find that post and answer it and I'll up-vote it. – gravyface Apr 26 '10 at 13:16
  • Does it only affect Mailbox level recovery or is the whole Exchange recovery process basically broken in the BETA/RC? When try a database level restore I only get the option to overwrite the existing MDB and the option to recover the the RDB is greyed out. – ITGuy24 Apr 26 '10 at 13:57

Saw this while browsing blogs and didn't know if it would help you. Link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.