The machine is a brand new Dell Precision m6500, Core i5, 8GB RAM. Windows Server 2008 R2 (fully patched) with Hyper-V Role Enabled.

Virtualization options in the BIOS are ON, SpeedStep is OFF, couldn't find C1E option in the BIOS to turn it off (I also got the impression that SpeedStep is C1E, but the Intel Product site lists them as separate "features." shrug)

The server stops responding without any apparent reason. I've tried testing in multiple scenarios, all of which result in a crash at seemingly random times:

  1. With the Server sitting idle, no apps running.
  2. Server sitting idle with a Virtual Machine running.
  3. Using a BurnInTest application

There's no blue screen. It doesn't restart. The screen just sits there. The keyboard backlight still responds and comes on with input, but nothing on the screen changes. There are no errors in the error log. I have to hold down the power button to turn it off. Doing memory tests on bootup results in no errors with the memory.

I have a second identical system and the same thing happens there too. I've dual-booted into Windows 7 Profession x64 on this system with no problems. Further testing has shown that the issue is definitely related to Windows Server 2008 R2 and Hyper-V as it appears the crashing does not happen when the services are not running.

I've installed all hotfixes relating to this issue (that I could find): 975530, 979444, 979491, 976427

System is still crashing without response.

  • 1
    Just an update to the functionality of this problem: Originally it had appeared that the system would only crash if the three Hyper-V services (Hyper-V Image Management Service, Networking Mgmnt Svc, Virtual Machine Mgmnt) were running. But this is not the case. The system will crash regardless of if these services are running.
    – blackf0rk
    Apr 22, 2010 at 15:19

6 Answers 6


Bios, drivers, hardware check. Pretty much the only thing I can point to. I had problems with various on board network card at times. Bad RAM, all that. Hyper-V servers are STABLE if everything works properly to start with, so you definitely look at either a hardware or a driver level problem (well, plus BIOS).

  • BIOS version is at "A02" Latest available patch version is at "A02." Unless there's some other sub-version that I am unaware of, my BIOS Is up-to-date. RAM is fine; I've done this check. Remember also that this problem isn't just happening on one machine - it's happening on two. So the chances of it being the same hardware problem (like RAM) is small.
    – blackf0rk
    Apr 22, 2010 at 13:37
  • Yes and no. Call dell - maybe they have a problem with some. Basically flag the machines as "defective per warranty".
    – TomTom
    Apr 22, 2010 at 14:15
  • The workstation didn't come with Windows Server 2008 R2 installed. It came with Windows 7 Professional. I doubt Dell would support the system with a different user-installed OS.
    – blackf0rk
    Apr 22, 2010 at 22:24
  • Hm, given the little fact that 2008R2 and Win7 are identical kernel wise, I would love to discuss that with Dell. Publicly. With the attorney general involved (accusaion: product fraud).
    – TomTom
    Apr 23, 2010 at 4:17
  • We just had a Dell tech come out and replace the motherboard - no effect.
    – blackf0rk
    May 13, 2010 at 17:58

Applying the work around described at the bottom of http://support.microsoft.com/kb/975530 seems to have worked and I can no longer reproduce the problem by a) copying large files across the network or b) leaving the laptop to run over night.

Just installed the hotfix and re-testing now with the aim of rolling back the workaround (as per KB recommendation).

  • The error that this hotfix addresses doesn't appear to be the error that's being reported on within this thread as this "CLOCK_WATCHDOG_TIMEOUT" hotfix doesn't work for both of my systems that are affected.
    – blackf0rk
    May 5, 2010 at 17:58
  • Ditto, I haven't actually seen any events relating to CLOCK_WATCHDOG_TIMEOUT either but was seeing The computer has rebooted from a bugcheck events right before the BSOD and some reports out there noted the bug check message and clock watchdog together in the same event. Hotfix installed and workaround rolled back--machine made it through the night and I've been moving files all morning. I'm not quite ready to call this one for myself but things are looking up. Have you tried just the reg hack described in the workaround?
    – Michhes
    May 6, 2010 at 1:46
  • Yes, the registry change had no effect either.
    – blackf0rk
    May 10, 2010 at 14:09

Could still be a hardware problem or hardware incompatibility... but you could try installing the free Hyper-V Server R2 and see if it does the same just for kicks.

Updating BIOS to the latest version seems to have fixed several people's freezing Dells when running Hyper-V. NIC drivers and possibly firmware are also important to keep up-to-date on.

  • Given that Hyper-V server nad Hyper-V role are identical - what is the sense of that?;)
    – TomTom
    Apr 22, 2010 at 9:35
  • Mainly just for fun ;) ...or see if it's conflicting with some other services that are used on a full-blown Windows server. Apr 22, 2010 at 10:10
  • As mentioned before, the only flagged device is the "Broadcom USH." So I'll update that and see if it doesn't fix it. Since it's happnening exactly the same way on another identical system, I have to believe then that it's happening to all systems. I find it hard to believe that I am the only one with a Dell Precision m6500 running Server 2008 R2.
    – blackf0rk
    Apr 22, 2010 at 13:41
  • Well a driver problem don't usually show up with a nice flag ^^ Same goes for BIOS revision problems. If this is a new model, generic problems in both drivers and firmware may very well exist that aren't yet sorted. Hyper-V needs hardware support for DEP and VT among a few other things and their usage may be a trigger for the problem if not implemented properly... Apr 22, 2010 at 14:25
  • This is a Core i5-520M: ark.intel.com/… It supports both, unless my eyes are crossed?
    – blackf0rk
    Apr 22, 2010 at 14:45

Have you left enough RAM for the Host Machine to run its processes? With Hyper-V you should reserve 2 gigs or more of RAM so the Host can run the processes which support not only it system but the applications (i.e. Hyper-V) running on top of it.

  • The Hyper-V Server host crashes without any VMs running. This isn't an issue within a VM. It's an issue on the actual Hyper-V host.
    – blackf0rk
    Apr 23, 2010 at 21:00

I have the machine (working on it now) with WS2K8R2.

All my BSOD issues (with HV) cleared when I reverted to the standard VGA video driver. I bought the ATI 4470 onboard video because I anticipated video issues and didn't want to drop the coin on NVidia.

The one and only thing I cannot do at this point is use the video out to hook up to a projector. This turns out to be a big fat hairy deal for me, though. I just ordered an external USB-video adapter to see if that will get me external video hookups.

Now that I am no longer experiencing BSOD due to the video driver, I love this thing. Would never part with it.

  • This is a known issue between Hypervisor and "high end" graphics cards. It is also a separate issue from the one originally posted. I replaced the video card in the M6500 with a lower-end nVidia graphics card (one from a 6400 which does work with Hypervisor) and it had no effect on the original issue - it still crashed. Also, it's important to note that the original problem here isn't a BSOD! The problem is the system just halting; with no BSOD - it just stops, screen frozen.
    – blackf0rk
    May 26, 2010 at 13:11
  • The first time I installed the OS I had the lockup issue with a black screen during login. Was on the verge of returning the machine, in fact. I re-installed the OS and went through all of the driver installs except the video and got it all going. I did not add the hyper-v role until after all drivers were on board. At that point, I got a working OS. Finally, I flipped on the HV role and have been good to go every since.
    – David Starr
    May 27, 2010 at 10:53
  • Thanks David. Unfortunately that's one of the processes that I went through with one of the machines and didn't work for us. :( Let me know if it continues to work for you.
    – blackf0rk
    Jun 4, 2010 at 12:43

I had the same issue and was able to find a fix. The fix is to install SP1 for Windows 2008 R2. Currently it is in RC stage, which is about as good as RTM, so don't be afraid to use it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.