I have been working on this for a few hours now, and haven't yet been able to get munin to output the html files/generated graphs of resource usage on my CentOS 5.3 server.

Here are some things I run as the munin user, and the results:

/usr/share/munin/munin-update --nofork --debug

(above works fine, takes ~2.4 seconds to complete)

munin-run cpu

(And other options/plugins (besides 'cpu'), all work fine and give desired output)


Fails with:

[FATAL] There is nothing to do here, since there are no nodes with any plugins.  Please refer to http://munin-monitoring.org/wiki/FAQ_no_graphs at /usr/share/munin/munin-html line 38

I am wondering if, perhaps, the settings in my munin.conf file might be causing a problem. Here's the contents of that file (below):

bdir   /var/lib/munin/
htmldir /home/archdev/public_html/monitoring
logdir  /var/log/munin
rundir  /var/run/munin/
tmpldir /etc/munin/templates

        use_node_name yes

Also, when I run the telnet localhost 4949 command, and list the node's plugins, it returns the default munin list... something seems to be wrong with the munin html creation process. :(

I'm running version 1.4.3.

  • Also, after checking the logs, I found the following: munin-update.log: Everything looks fine. (2.40 sec) munin-limits.log: Everything looks fine. (0.00 sec) munin-graph.log: Everything looks fine. (0.00 sec) munin-node.log: Output below --> 2010/04/21-23:10:01 CONNECT TCP Peer: "" Local: "" 2010/04/21-23:10:04 [11182] Service 'yum' exited with status 2/0. munin-node.log: Getting the [FATAL] error as outlined above on every run. – geerlingguy Apr 22 '10 at 4:15
  • Are you running munin-cron as root or as the munin user (and have you run munin-cron as root in the past)? – Dave Forgac May 22 '10 at 3:08

I ended up installing munin (an older version) via the cPanel/WHM interface, and everything is working fine now. Strange...

| improve this answer | |

There was probably no plugin enabled. Check with

munin-node-configure --suggest --shell

execute those commands and bam it should work. This usually gets done at startup but requires python.

| improve this answer | |
  • Please see my latest post - this didn't help :( – geerlingguy May 3 '11 at 17:01

Well, now I'm configuring another CentOS 5.5 server, and I installed Munin 1.4.5 from the EPEL repo (I was running 1.2.5 from the standard CentOS repos, and it was working fine). Since installing 1.4.5, I'm getting no graphs, and the same errors in the logs... also, since I'm using Klaxo on this server (ugh), I can't use WHM/cPanel's automated installer to get the latest version running.

I've run $ sudo /usr/sbin/munin-node-configure --shell, but that did nothing (it sits for a few seconds, then returns to the prompt. It's supposed to output a bunch of ln -s lines for making symlinks to plugins (which I could pipe to the shell using | sudo sh, but it doesn't.

Additionally, the /var/www/html/munin directory was created, but it doesn't contain any server-specific files/graphs (it only contains the basic Munin stylesheets and graphics).

If I take a peek into /etc/munin/plugins, it's full of plugins. So I don't know why munin-node is not working... very strange indeed! I've tried all the steps in Munin's FAQ_no_graphs page, but nothing helped.

[Edit: Just looked at munin-update.log, and found the following:

[ERROR] Hostname 'servername_vps2' contains illegal characters (http://en.wikipedia.org/wiki/Hostname#Restrictions_on_valid_host_names).  Please fix this by replacing illegal characters with '-'.  Remember to do it on both in the master configuration and on the munin-node.

... it seems I'll have to use the FQDN for the server (as reported by doing a telnet to the server on port 4949) instead of a custom name (with an underscore) as I did with 1.2.5. We'll see if this works...]

| improve this answer | |
  • 1
    Looks like I needed to edit munin.conf in /etc/munin and make sure the hostname matched the reported hostname. Annoying, but at least it's working now. – geerlingguy May 3 '11 at 17:14

I had the same problem. Reason: in munin.conf I had only 1 node "localhost" and this was not the same munin thought about itself.


telnet localhost 4949
# munin node at your.domain.com

So I put "your.domain.com", i.e. your FQDN instead of localhost in munin.conf.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.