We have successfully implemented a Samba Primary Domain Controller for a hybrid Windows-Linux environment. So now I am setting up dual-boot clients with Windows XP and Ubuntu 9.10.

Windows XP can be easily added to the Samba Domain. Everything is manageable. No worries. But when I try using likewise-open 4.1 to add the Ubuntu 9.10 to the samba domain, it cannot locate the domain controller.

domainjoin-cli --loglevel verbose join MYDOMAIN root

Error: Unable to resolve DC name [code 0x00080026]

Resolving 'MYDOMAIN' failed. Check that the domain name is correctly entered. Also check that your DNS server is reachable, and that your system is configured to use DNS in nsswitch.

I even tried mydomain.com variations but to no avail. What am I missing ?

I read up a document on MSDN wherein it says that the Domain Controller creates some SRV records in the DNS server. I guess, I don't have them on my BIND. Do you think that is the problem ? If yes, can anyone please point out how and what SRV records need to be added.



If you have Samba as a PDC, you don't need likewise. Just install samba and follow the instructions to join the samba domain at http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/FastStart.html#id2555963

Likewise assumes an Active Directory Domain Controller. If you want a Samba to have those functionalities, you need to go for Samba4 (not yet recommended for production). The errors you're getting is because you don't have DNS and Kerberos configured has expected in a domain controller (for example, try resolving _tcp.<DOMAIN>).

Best of luck,
João Miguel Neves

  • Hi jneves! Thanks for the solution. It solved my problem, but partly. Now the ubuntu machine is a part of the domain, but only for namesake, as it yet doesn't allow logins for users from ldap. I guess I will have to tweak PAM for that. Thanks anyways :) – Knight Samar May 8 '10 at 13:21
  • You can use pam_winbind or pam_ldap for that (pam_winbind will be easier as you already have samba configured for the domain). – jneves May 10 '10 at 16:11

Is your domain controller listed in /etc/resolv.conf in the Ubuntu hosts you're trying to join to the domain?

What happens when you try

ping mydomain.com


nslookup mydomain.com

from the Ubuntu hosts?

Update: There are some suggestions for the error you're getting in a post and comments here. However, the current version of Likewise is 5.3, which is a bit ahead of the one you're using from the Ubuntu Karmic repository. If none of the steps mentioned in the link above resolve the issue, the next step I would take would be to download the current version of Likewise for Ubuntu/Debian here and the quick start guide here (pdf), upgrade, and see if this is fixed in the latest version.

There is also an implementation guide to using Likewise with Samba here (pdf).

  • Yes, it can nslookup and ping mydomain.com And my /etc/resolv.conf is: search mydomain.com nameserver I think it has something to do with the SRV records...this was the document I had read at Microsoft's Site – Knight Samar Apr 24 '10 at 15:09
  • @Knight see update with further suggestions above. – nedm Apr 24 '10 at 23:40
  • thanks for the quick and extended help! Sorry, I was busy on other things so I couldn't reply. I tried the solution from the link as well as installing likewise-open 5.3.0-1, but it is still raising the same error :( – Knight Samar May 4 '10 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.