2

Back in the olden days, runlevel 3 was text mode and runlevel 5 was GUI mode. So if you wanted Linux to boot up in text mode, you would just set 3 as the initial runlevel and you're done.

Nowadays it seems that things are more complicated, and since I don't want to break anything, I ask:

What's the right way to get Ubuntu 9.10 to always boot up in multiuser text mode?

  • I assume that you also use the program called "screen" right? ;-) – djangofan Apr 27 '10 at 23:51
4

You can either disable gdm or directly add a "text" argument to grub. See komputes reply in http://ubuntu-ky.ubuntuforums.org/showthread.php?t=1322949.

| improve this answer | |
2

Basically, you'll want to remove GDM (GNOME Display Manager) from the list of started services at the runlevel 5.

update-rc.d -f gdm remove
| improve this answer | |
  • I haven't run that yet, but "find /etc/rc*.d | grep gdm" prints nothing. How do I figure out which rc script is launching gdm? – mike Apr 27 '10 at 23:46
  • look inside /etc/init.d/ – sybreon Apr 28 '10 at 2:15
1

For Ubuntu 11.10 Oneiric Ocelot, they switched from GDM to LightDM. The "text" parameter in the kernel command line (editing /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT="text") was a hack that GDM did to test if it should not start. (One might ask why they didn't further that hack when they changed from GDM to LightDM, but that's Linux for ya).

Now you need to make a file /etc/init/lightdm.override that contains "manual" on a line by itself. Apparently it handles comments, if you want to make a note to yourself about this.

References here and here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.