I have an outgoing message that has and is stuck in a queue on my backend mail server. The queue is:

Internet Mail SMTP Connector (MY_FRONT_END_SERVER_NAME)-524350ff...

It is in state retry with 183 failures. It is only one message and all other mail is flowing. The message is not particularly large. My limited understanding, a guess really, is that this message should get handed off to the front end mail server and sent to the remote hosts for which it is destined, so it should even matter if the remote host is up. However, I can telnet to the smtp provider of that host.

How can I find out why it is stuck in this queue, and can I force it out somehow (unfreeze doesn't help me)?


For more information, you can go into ESM and look at the queue. From the wording of your question, it sounds like you're already there. When you click on the name of the queue (name of the domain the mail is to be routed to), in the bottom pane there is a little box "Additional Queue Information" where you can get more info on why it's stuck in that queue. A quick google search after that might yield results.

EDIT: Based on your comments, I would look at this.

EDIT: For further troubleshooting, here are some links I would look at

Turning on Diagnostic Logging for Exchange 2003 <-- generates more info in Application Log in Eventvwr

How to use Queue Viewer to troubleshoot mail flow issues in Exchange Server 2003

Technet article regarding Event ID 4007 source MSExchangeTransport (good links here)

XFOR: Telnet to Port 25 to Test SMTP Communication <--I would try this first for any mail stuck in the queue issue first.

I just had to troubleshoot a mail queue problem in my own environment, and it turns out we don't have our PTR record set up for Reverse DNS 0_o

  • Ah, I was blind to that, it says unable to open message for delivery. – Kyle Brandt Apr 28 '10 at 20:48
  • Interesting... Seems maybe like the message was already deleted? – Campo Apr 28 '10 at 20:54
  • I don't think it was deleted because it keeps trying to resend. IT seems like the new one is queued too....hmmm... I believe this is a meeting invite. – Kyle Brandt Apr 28 '10 at 20:58
  • Second one is now in state retry as well. – Kyle Brandt Apr 28 '10 at 20:59
  • 1
    @Kyle unfortunately that error is pretty generic, and I imagine you would need more info about the message being sent. That being said, would this : support.microsoft.com/kb/938650/en-us have any bearing on the discussion? – Holocryptic Apr 28 '10 at 21:07

If unfreeze didn't work did you try to force?

Try this:

Open Exchange System Manager: First Administrative Group > Servers> "Server Name" > Queues

Right click the queue in question and click Force Connection.

It could fail for a few reason Message size to large recipient doesn't exist or is unreachable domain does not exists or is unreachable etc...

You can click find messages and search for it. If there is only one that will make it easy. Check out the properties see if that sheds some light on it.

  • Message is only 18k, unfreeze had not helped, just tried force and still no luck :-/ – Kyle Brandt Apr 28 '10 at 20:05
  • Is the message even important? Just delete and inform the user. I am pretty sure you can send an NDR when you delete – Campo Apr 28 '10 at 20:10
  • I told him to send another copy, I don't want to delete this yet because I want to find out why this has happened. – Kyle Brandt Apr 28 '10 at 20:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.