1

My website was working locally on my

Win 7 64 bit machine. I then installed VS2010 opted to not upgrade to .NET 4.0

Now when i go to my site i get the following error

HTTP Error 500.0 - Internal Server Error Calling LoadLibraryEx on ISAPI filter "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_filter.dll" failed

In the event log i get

Could not load all ISAPI filters for site 'ESTORE'. Therefore site startup aborted.

The site is using "DefaultAppPool" and Enabled 32-bit Application is set to True

1

OK, a little dumb on my part. I set Enable 32 bit back to true and it worked.

0

What version of .NET is associated with DefaultAppPool?

You need separate app pools for .NET 2.0 (with or without 3.0 & 3.5 assemblies) and 4.0.

(The .NET 4 installer run by VS2010 created separate 4.0 app pools, but that could be an artefact of previously having RC installed.)

  • Richard, DefaultAppPool is set to v2.0.5. I didn't install the rc. Just the full version that came out the other day. – Frosty May 1 '10 at 18:38
0

If the Enable 32-bit flag won't work for you, try to check your ISAPI filters in IIS. I had some mysterious additional .net ISAPI filter on my dev machine that I couldn't account for in there (probably from some .net RC build I installed), and after removing/disabling it, all was working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.