5

I recently upgraded computers to Windows 7 Professional and am running IIS7. When I'm on my computer I can easily access localhost through my web browser but when I try from another computer on my network (replacing localhost with my computer name) it doesn't work. I also tried using "computername.domain.com" and still no luck. I can access other computers running Windows XP and IIS 5 but I'm having no luck accessing my own from another computer. I checked and my IIS7 has anonymous users enabled. Am I missing any other setting? Is this an IIS7 thing or am I missing a setting?

Thanks in advance!

  • can you please provide more specifics, such as the error message received? – Michael Gorsuch Apr 29 '10 at 15:16
  • 1
    do you have a firewall enabled on the windows 7 machine? from another machine can you "telnet 192.168.0.1 80" assuming 192.168.0.1 is the win7 machine? – johnh Apr 29 '10 at 15:24
  • Michael: It's actually not giving me any errors. The browser just says that it can't connect to <computer-name> Johnh: I just tried to telnet and it couldn't connect. Do you know where I can setup my firewall in Win7? – Adam Apr 29 '10 at 15:31
5

As @Johnh said it is most likely your firewall.

Open up port 80 on your firewall or whatever port you are hosting the local site on should it be a nonstandard port.

+1 for testing with telnet. Will give you a quick and definit answer on if the Web Server has the proper port open.

5

Campo is correct, you most likely need to open a port. Here's how: (on windows 7)

  1. Open Control Panel
  2. Windows firewall
  3. Select advanced settings
  4. Select Inbound rules
  5. Select "New Inbound Rule"

    Specify local ports 80, 8081. Allow Domain

    (More details at: http://maximumpcguides.com/windows-7/open-a-port-in-windows-7s-firewall)

0

go to Control Panel>Windows Firewall>Allowed Programs and make sure that World Wide Web Services (HTTP) is checked.

0

Open Control Panel Windows firewall Select advanced settings Select Inbound rules Select "New Inbound Rule"

Specify local ports 80, 8081. Allow Domain

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.