1

I have installed PHP 5.2.13 through Web Platform Installer on IIS 7.5/windows 2008 R2
Now I'm trying to install additional PHP extensions, such as mcrypt, so I downloaded the compiled .zip file from the php windows binaries site.
I put the relevant dlls in the extensions folder, and added the lines in the php.ini:

[PHP_MCRYPT]
extension=php_mcrypt.dll

After restarting IIS, no application was working.
This was with VC6 compiled/non thread-safe compiled version of PHP 5.2.13 .zip package.
I also tried with the thread-safe version, which prevented IIS to restart and forced me to reboot the server.

What am I doing wrong here?

  • php_mcrypt.dll has a dependency on libmcrypt.dll. Did you make libmcrypt.dll available to IIS? – bzlm May 25 '10 at 16:36
  • That was exactly the reason why it wasn't working, as I found out later. Please add that as an answer and I'll choose it! :) Basically, IIS needs that version of PHP as I have written above, and any extension from that compiled package should work just fine (provided the dependencies are in place too). – Razor May 26 '10 at 17:55
0

Just as bzlm commented:

php_mcrypt.dll has a dependency on libmcrypt.dll. Did you make libmcrypt.dll available to IIS?

That was the reason. Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.