I'm trying to configure an image for deployment to other machines. I've configured the machine, then I run sysprep, choose generalize and OOBE. Sysprep does its thing, then reboots. Then when 'setup is starting services', I get a 'Windows could not finish configuring the system', and it advises to reboot and try again, which presents the same error. I've tried uninstalling symantec endpoint antivirus, but this does not prevent the issue. Where should I look for what is causing the problem? Is there a logfile?


This was solved by un-installing classroom presenter 3. It would still be useful to know if there is a logfile to prevent further guesswork.

| improve this answer | |
  • @victor You may want to consider accepting your own answer, see here for more details. – squircle Jun 12 '10 at 3:24

There is a logfile and you can view it. When you see the error window, you can press Shift-F10 for a cmd window, start powershell.exe and cd to c:\windows\panther, then :

tracerpt setup.etl
(Get-Content ./dumpfile.xml)[-1 .. -100]

to inspect the last 100 lines of the log. You can (and you probably want to) search through this file :

Select-String ./dumpfile.xml -pattern 'reg key'

This searches for the specific registry key that could not be processed.

| improve this answer | |

Having the WAIK toolkit installed on the machine being sysprep'd seems to also cause this error. Best to uninstall it before doing a sysprep.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.