13

Is there a way to know if the Red Hat Linux Servers on my network have IP Multicasting enabled? The output that I get by running the cat /proc/net/igmp command is the following

Idx Device    : Count Querier   Group    Users Timer    Reporter
1   lo        :     0      V3
                010000E0     1 0:00000000       0
2   eth0      :     3      V3
                010000E0     1 0:00000000       0
  1. Does this mean that IP Multicasting is enabled on my network?
  2. Does this also mean that th server from which I ran the cat command belongs to Group 1?
16

To check if multicast is enabled on the interface do a "ifconfig eth0" and look for: MULTICAST

  • ifconfig command is not enabled on the servers on our network. – Swapnonil Mukherjee May 3 '10 at 9:33
  • 2
    On RedHat-flavour systems normal users don't have /sbin (where ifconfig lives) in their path. If you're on a RedHat-like system and not the root user try running it as /sbin/ifconfig. – markdrayton May 3 '10 at 10:19
  • Thanks Mark, Running ifconfig from sbin gives me the following output eth0 Link encap:Ethernet HWaddr 00:14:22:1A:AF:DB inet addr:10.1.0.74 Bcast:10.1.7.255 Mask:255.255.248.0 inet6 addr: fe80::214:22ff:fe1a:afdb/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:70747195 errors:0 dropped:0 overruns:0 frame:0 TX packets:6965432 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:100 I can see MULTICAST in the output. – Swapnonil Mukherjee May 3 '10 at 10:37
  • Your eth0 interface has multicast enabled :) – rkthkr May 3 '10 at 10:53
  • 9
    "netstat -g" will give you group membership information. – rkthkr May 3 '10 at 10:57
6

According to howto

cat /proc/net/igmp 

will show the groups you are currently subscribed to

  • how can I subscribe to other groups or interfaces?? which I got from netstat -g – lazarus Nov 10 '14 at 20:25
0

These days, iproute2, or rather its ip command will also give you the answer:

$ ip link

(or ip l for short)

will present you with something like this:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 [...]
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 [...]
    link/ether ab:cd:ef:12:34:56 brd ff:ff:ff:ff:ff:ff

where you can see that there is no multicast on my loopback device, but yes, my ethernet port does indeed do multicast.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.