1

When I'm trying to use pecl to install apd it compiles the extension for a 64 bit system. Since MAMP needs extensions in i386 mode, apache won't load this apd.so file.

So how can I force pecl to compile the extension in i386 mode?

Thanks for any help!

2

Let you try the blow commands.

% pecl download apd-or-whatever
% tar zxvf ***
% cd the-directory
% /Applications/MAMP/bin/php5/bin/phpize
% ./configure CFLAGS="-arch i386" --with-php-config="/Applications/MAMP/bin/php5/bin/php-config"
% make
% make install

I'm using MAMP1.8.4 with manually compiled PHP5.3.2. In MAMP1.9.x, the paths of phpize and php-config are different.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.