I work for a small non-profit organization. We have about 35 administrative employees who use e-mail. We're on a Windows network with a domain. Everyone is running XP Pro and Office 2007 with all updates/patches.

We used to use POP3 mail through a local provider. However, we recently signed-up for a free Google Apps account, and we switched to IMAP mail through Google. Everyone uses Outlook 2007 as the client.

For about ten days, everything was working fine. Yesterday afternoon, we suddenly developed a strange and annoying problem. Every time you send an e-mail message, a copy of your outgoing message shows up in your inbox. It's as if you're adding your own address to the CC: line of every message.

Nothing has changed on our end. I was hoping that the problem was a temporary glitch that would resolve itself, but here we are about 24 hours later, and it's still happening.

I searched Twitter, and there were a handful of vague messages about issues with Google mail and IMAP, but I didn't see any references to this specific problem.

Any thoughts on what's going on here and how to fix it?

2 Answers 2


Google's IMAP uses a pseudo-namespace that isn't a 100% mapping to how Outlook works (which uses distinct, separate boxes). It could be that you are seeing the message as part of a namespace issue due to the fact that all messages are retained (stored) in a "single" inbox server-side, but when you make a sub-mailbox in Google, you're really creating what amounts to a filter that is applied server-side at Google's end. Google maintains the "illusion" of separate boxes by filtering out what is sent back to the client, so that a compliant IMAP client will see only those things that are in INBOX, etc. A broken IMAP namespace will break the illusion and create all kinds of havoc - in essence, what you are seeing now. It also doesn't help that, while Outlook 2k7 supports IMAP, it's not "good" at doing so.

Do this as a test: see if email sent not only to another person but also CC:'d to themselves shows up once or twice. If it's twice, there is a namespace issue that is mapping mail from Google's "Sent" folder (aka filter); one email that was the CC: in the "INBOX", and one email that was from the "Sent".

Another test: download Thunderbird and hook up an IMAP account to the Google mailbox. If the "sent" items that show up in Outlook, but don't show in Thunderbird, that is also an indication of a borked IMAP namespace.

Another thing to consider is that a setting has been misconfigured for where Sent items are stored. Check both the client and the server (by logging into the Gmail account via the web interface, and checking settings there)


OK, I found out the answer myself.

When I wrote earlier that "nothing had changed on our end", that wasn't entirely accurate. We had experienced some problems with our own messages to each other being flagged as spam, so I added a filter to everyone's account which said that any message originating from our own domain should never be sent to spam.

Well, bizarrely, adding this filter causes outgoing messages to be copied into your inbox:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.